summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2018-12-17 14:12:19 +0100
committerPieter Goetschalckx2018-12-17 14:12:19 +0100
commit9423fbde14ccaf67ae03b675101521f2cbf9aaac (patch)
tree016dedddfd83c6ab3940baf5717c90dadeb0471c
downloadaur-python-requests-threads.tar.gz
Initial import
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD24
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2e8b23fdac3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-requests-threads
+ pkgdesc = Twisted Deferred Thread backend for Requests
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://github.com/requests/requests-threads
+ arch = any
+ license = unknown
+ makedepends = python-setuptools
+ depends = python-requests
+ source = https://github.com/requests/requests-threads/archive/v0.1.1.tar.gz
+ sha256sums = 479292ad0f958fd2932365399fbc0e00dfa0185c409bfa35339cb8fbf66485fe
+
+pkgname = python-requests-threads
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7690670f2b44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Pieter Goetschalckx <3.14.e.ter <at> gmail <dot> com>
+
+pkgname=python-requests-threads
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="Twisted Deferred Thread backend for Requests"
+arch=('any')
+url="https://github.com/requests/requests-threads"
+license=('unknown')
+depends=('python-requests')
+makedepends=('python-setuptools')
+source=("https://github.com/requests/requests-threads/archive/v$pkgver.tar.gz")
+sha256=('')
+
+build() {
+ cd requests-threads-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd requests-threads-$pkgver
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+}
+sha256sums=('479292ad0f958fd2932365399fbc0e00dfa0185c409bfa35339cb8fbf66485fe')