summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLukas Fleischer2024-09-21 22:07:23 -0500
committerLukas Fleischer2024-09-21 22:07:23 -0500
commite9c10ce8b06271db014e88b20663a6db9083871c (patch)
treecb12df3822ee4fe57fe622d591cdbb21d380fda2
downloadaur-e9c10ce8b06271db014e88b20663a6db9083871c.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d20548eef673
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-resend
+ pkgdesc = Resend's Python SDK
+ pkgver = 2.4.0
+ pkgrel = 1
+ url = https://github.com/resend/resend-python
+ arch = any
+ license = MIT
+ makedepends = python-build
+ makedepends = python-setuptools
+ makedepends = python-installer
+ makedepends = python-wheel
+ depends = python>=3.6
+ depends = python-typing_extensions
+ depends = python-requests
+ source = https://github.com/resend/resend-python/archive/refs/tags/v2.4.0.tar.gz
+ sha512sums = a073bb9ce11e6ba23399d72f7f4d58cbcc51be97c7f7cb24ba45fd42c38433886fd5d6882e1dd6206602b886a713c3ecf8422f8ebe8d27e9ffac1877c7b62aff
+ b2sums = cfb9acc8554c01e94405bbaf33600d96f367eacbc0eeac231b0df858c062f23a26b0434fc6c1f0d56d2faebdcafdcb7b862b05a3973284d8e330ce298eb9ff2b
+
+pkgname = python-resend
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4eea726463df
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
+
+_name=resend-python
+pkgname=python-resend
+pkgver=2.4.0
+pkgrel=1
+pkgdesc="Resend's Python SDK"
+arch=('any')
+url="https://github.com/resend/${_name}"
+license=('MIT')
+depends=('python>=3.6' 'python-typing_extensions' 'python-requests')
+makedepends=('python-build' 'python-setuptools' 'python-installer' 'python-wheel')
+source=("https://github.com/resend/resend-python/archive/refs/tags/v${pkgver}.tar.gz")
+sha512sums=('a073bb9ce11e6ba23399d72f7f4d58cbcc51be97c7f7cb24ba45fd42c38433886fd5d6882e1dd6206602b886a713c3ecf8422f8ebe8d27e9ffac1877c7b62aff')
+b2sums=('cfb9acc8554c01e94405bbaf33600d96f367eacbc0eeac231b0df858c062f23a26b0434fc6c1f0d56d2faebdcafdcb7b862b05a3973284d8e330ce298eb9ff2b')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+}
+