summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoakim Saario2021-06-04 19:37:10 +0200
committerJoakim Saario2021-06-04 19:39:50 +0200
commit22cf08c11016f67fefc39317715182edcd032721 (patch)
tree4b60eedd0239607057837922031e2d6b82fa18fd
downloadaur-22cf08c11016f67fefc39317715182edcd032721.tar.gz
Version 0.17.0
-rw-r--r--.SRCINFO14
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD34
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e36a68a28df8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-respx
+ pkgdesc = Mock HTTPX with awesome request patterns and response side effects
+ pkgver = 0.17.0
+ pkgrel = 1
+ url = https://github.com/lundberg/respx
+ arch = any
+ license = BSD
+ checkdepends = python-nox
+ makedepends = python-setuptools
+ depends = python-httpx
+ source = python-respx-0.17.0.tar.gz::https://github.com/lundberg/respx/archive/refs/tags/0.17.0.tar.gz
+ sha512sums = 2f5fd27c81a62cc3da45a1c9a40c95a9e480511567f9613e0ecac8991234f0d9e4e2ecfba0b3e294090d9a0f34c66ceaf32a779856c3106411057946e1adefbc
+
+pkgname = python-respx
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9f98d1e8e50b
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*
+!/PKGBUILD
+!/.SRCINFO
+!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0ffc241321b3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer Joakim Saario <saario.joakim@gmail.com>
+
+pkgname=python-respx
+pkgver=0.17.0
+pkgrel=1
+pkgdesc="Mock HTTPX with awesome request patterns and response side effects"
+arch=('any')
+url="https://github.com/lundberg/respx"
+license=('BSD')
+depends=('python-httpx')
+makedepends=('python-setuptools')
+checkdepends=('python-nox')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/0.17.0.tar.gz")
+sha512sums=('2f5fd27c81a62cc3da45a1c9a40c95a9e480511567f9613e0ecac8991234f0d9e4e2ecfba0b3e294090d9a0f34c66ceaf32a779856c3106411057946e1adefbc')
+
+build() {
+ cd "${srcdir}"/respx-${pkgver}
+
+ python setup.py build
+}
+
+check() {
+ cd "${srcdir}"/respx-${pkgver}
+
+ python -m nox -k test -k test -p "$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')"
+ python -m nox -k check
+}
+
+package() {
+ cd "${srcdir}"/respx-${pkgver}
+
+ python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ install -Dm644 LICENSE.md "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE.md
+}