summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJim Heald2017-01-28 21:34:27 -0800
committerJim Heald2017-01-28 21:34:27 -0800
commit31b8688bef1863963f87d11869c4c80ccacc7f6f (patch)
treee29aae7a89cde54a130400660a9ff749cc1ee682
downloadaur-31b8688bef1863963f87d11869c4c80ccacc7f6f.tar.gz
First attempt
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD21
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..751709025440
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-restless-git
+ pkgdesc = A lightweight REST miniframework for Python.
+ pkgver = 2.0.3
+ pkgrel = 1
+ url = https://github.com/toastdriven/restless
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ provides = python-restless
+ options = !emptydirs
+ source = git+https://github.com/toastdriven/restless
+ sha256sums = SKIP
+
+pkgname = python-restless-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f384f8a746d6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,21 @@
+# Maintainer: Sigmund Vestergaard <sigmundv at gmail dot com>
+pkgname=python-restless-git
+pkgver=2.0.3
+pkgrel=1
+pkgdesc="A lightweight REST miniframework for Python."
+arch=('any')
+url="https://github.com/toastdriven/restless"
+license=('BSD')
+makedepends=('python-setuptools')
+provides=('python-restless')
+options=(!emptydirs)
+source=("git+https://github.com/toastdriven/restless")
+sha256sums=('SKIP')
+
+package() {
+ cd "$srcdir/restless"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+
+# vim:set ts=2 sw=2 et: