summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrazer2020-12-24 07:11:30 +0100
committerrazer2020-12-24 07:11:30 +0100
commitb6f2fca29b58fa8ef85d1893867e64670702b9fe (patch)
treeea8347b8b00c84bff9e58d8535d645b1a8276f83
parenta5640aeb82daa7360c103bf34ecce821375f36fc (diff)
downloadaur-b6f2fca29b58fa8ef85d1893867e64670702b9fe.tar.gz
Patch solving build issue
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
-rw-r--r--boost-include.patch10
3 files changed, 22 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ce1a1e9c2b6e..396dc47cafde 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-rf24
pkgdesc = Python bindings for RF24 radio modules
pkgver = 1.3.9
- pkgrel = 1
+ pkgrel = 2
url = http://tmrh20.github.io/RF24/
arch = any
license = GPL2
@@ -11,7 +11,9 @@ pkgbase = python-rf24
depends = python
depends = rf24
source = https://github.com/nRF24/RF24/archive/v1.3.9.tar.gz
+ source = boost-include.patch
sha256sums = 7fc2d32a3a226faa78e60ba472ad40f3da97d4d158845f9603d41e1cf8f31ae4
+ sha256sums = 80439c7ae3c30c93e8da055b753bbe047da22815041aea048d723afd75ea1a39
pkgname = python-rf24
diff --git a/PKGBUILD b/PKGBUILD
index 4e2dc228c859..b860c27f22fc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,21 @@
# Maintainer: Razer <razer[AT]neuf[DOT]fr>
pkgname=python-rf24
pkgver=1.3.9
-pkgrel=1
+pkgrel=2
pkgdesc='Python bindings for RF24 radio modules'
arch=(any)
url='http://tmrh20.github.io/RF24/'
license=('GPL2')
depends=('boost-libs' 'python' 'rf24')
makedepends=('boost' 'python-setuptools')
-source=("https://github.com/nRF24/RF24/archive/v${pkgver}.tar.gz")
-sha256sums=('7fc2d32a3a226faa78e60ba472ad40f3da97d4d158845f9603d41e1cf8f31ae4')
+source=("https://github.com/nRF24/RF24/archive/v${pkgver}.tar.gz" "boost-include.patch")
+sha256sums=('7fc2d32a3a226faa78e60ba472ad40f3da97d4d158845f9603d41e1cf8f31ae4'
+ '80439c7ae3c30c93e8da055b753bbe047da22815041aea048d723afd75ea1a39')
+
+prepare() {
+ cd "$srcdir"
+ patch --forward --strip=1 --input="${srcdir}/boost-include.patch"
+}
build() {
cd "$srcdir/RF24-$pkgver"
diff --git a/boost-include.patch b/boost-include.patch
new file mode 100644
index 000000000000..8aa1506ee887
--- /dev/null
+++ b/boost-include.patch
@@ -0,0 +1,10 @@
+diff --unified --recursive --text src/RF24-1.3.9/pyRF24/pyRF24.cpp src-patch/RF24-1.3.9/pyRF24/pyRF24.cpp
+--- src/RF24-1.3.9/pyRF24/pyRF24.cpp 2020-08-22 16:49:54.000000000 +0200
++++ src-patch/RF24-1.3.9/pyRF24/pyRF24.cpp 2020-12-24 06:57:15.028070430 +0100
+@@ -1,5 +1,5 @@
+-#include <RF24/RF24.h>
+ #include <boost/python.hpp>
++#include <RF24/RF24.h>
+
+ namespace bp = boost::python;
+