summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2019-05-25 14:11:53 +0100
committerGrey Christoforo2019-05-25 14:11:53 +0100
commit451891ceeac8b8429094c97f76cd2c01c317bcfb (patch)
treebdfd0c641fe40497e80fa9c129081aedb1867331
downloadaur-451891ceeac8b8429094c97f76cd2c01c317bcfb.tar.gz
initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD27
3 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a2badae2a6a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-rgt
+ pkgdesc = Regulatory Genomics Toolbox
+ pkgver = 0.12.1
+ pkgrel = 1
+ url = http://www.regulatory-genomics.org
+ arch = any
+ license = custom
+ makedepends = python-setuptools
+ depends = python
+ depends = python-numpy
+ depends = python-scipy
+ source = https://github.com/CostaLab/reg-gen/archive/0.12.1.tar.gz
+ sha256sums = baccb00d00dd98a26954414f13fd6f8f7d4ac1f6b40d65177867237029477fcf
+
+pkgname = python-rgt
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72a3ed3fe6e0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+*.tar*
+pkg/
+src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8ef6e5643b2c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
+
+pkgname=python-rgt
+_pkgname=reg-gen
+pkgver=0.12.1
+pkgrel=1
+pkgdesc="Regulatory Genomics Toolbox"
+arch=('any')
+url=http://www.regulatory-genomics.org
+license=('custom')
+depends=('python' 'python-numpy' 'python-scipy')
+makedepends=('python-setuptools')
+source=("https://github.com/CostaLab/${_pkgname}/archive/${pkgver}.tar.gz")
+sha256sums=('baccb00d00dd98a26954414f13fd6f8f7d4ac1f6b40d65177867237029477fcf')
+
+build() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py build
+}
+
+
+package(){
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:ts=2:sw=2:et: