summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGrey Christoforo2020-11-01 15:12:02 +0100
committerGrey Christoforo2020-11-01 15:12:02 +0100
commit8a259260435d943682b1971c048b96836c6a1b4e (patch)
tree92e2d73a971f93dd7ed0fdfc8263f0e53804ae21
parentd03ed3f4bcc4a3c3d7533cb5cbe0d1b094f4322b (diff)
downloadaur-8a259260435d943682b1971c048b96836c6a1b4e.tar.gz
bump version
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD25
2 files changed, 17 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 430662c45044..f560b02acf41 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-rgt
pkgdesc = Regulatory Genomics Toolbox
- pkgver = 0.12.1
+ pkgver = 0.13.1
pkgrel = 1
url = http://www.regulatory-genomics.org
- arch = any
- license = custom
+ arch = x86_64
+ license = GPL3
makedepends = python-setuptools
depends = python
depends = python-numpy
@@ -23,8 +23,8 @@ pkgbase = python-rgt
depends = python-moods
depends = python-fisher
depends = python-biopython
- source = https://github.com/CostaLab/reg-gen/archive/0.12.1.tar.gz
- sha256sums = baccb00d00dd98a26954414f13fd6f8f7d4ac1f6b40d65177867237029477fcf
+ source = https://github.com/CostaLab/reg-gen/archive/v0.13.1.tar.gz
+ sha256sums = 0c005325e3adac0746e36618747e24c9b2a2bdcb67c42305b680bfcfe562ae0f
pkgname = python-rgt
diff --git a/PKGBUILD b/PKGBUILD
index 60a33bd88c52..75fc0ee0fa8f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,31 @@
# Maintainer: Grey Christoforo <first name [at] last name [dot] net>
pkgname=python-rgt
-_pkgname=reg-gen
-pkgver=0.12.1
+pkgver=0.13.1
pkgrel=1
pkgdesc="Regulatory Genomics Toolbox"
-arch=('any')
+arch=(x86_64)
url=http://www.regulatory-genomics.org
-license=('custom')
-depends=('python' 'python-numpy' 'python-scipy' 'python-pysam' 'python-pybigwig' 'python-pyvcf' 'python-natsort' 'python-matplotlib' 'python-scikit-learn' 'python-matplotlib-venn' 'python-mpmath' 'python-htseq' 'python-hmmlearn' 'python-pyx' 'python-moods' 'python-fisher' 'python-biopython')
-makedepends=('python-setuptools')
-source=("https://github.com/CostaLab/${_pkgname}/archive/${pkgver}.tar.gz")
-sha256sums=('baccb00d00dd98a26954414f13fd6f8f7d4ac1f6b40d65177867237029477fcf')
+license=(GPL3)
+depends=(python python-numpy python-scipy python-pysam python-pybigwig python-pyvcf python-natsort python-matplotlib python-scikit-learn python-matplotlib-venn python-mpmath python-htseq python-hmmlearn python-pyx python-moods python-fisher python-biopython)
+makedepends=(python-setuptools)
+source=("https://github.com/CostaLab/reg-gen/archive/v${pkgver}.tar.gz")
+sha256sums=('0c005325e3adac0746e36618747e24c9b2a2bdcb67c42305b680bfcfe562ae0f')
prepare() {
- cd "$srcdir/$_pkgname-$pkgver"
- sed -i 's,pyBigWig==,pyBigWig>=,g' setup.py
+ cd "reg-gen-$pkgver"
+ #sed -i 's,pyBigWig==,pyBigWig>=,g' setup.py
}
build() {
- cd "$srcdir/$_pkgname-$pkgver"
+ cd "reg-gen-$pkgver"
python setup.py build
}
package(){
- cd "$srcdir/$_pkgname-$pkgver"
- python setup.py install --root="$pkgdir/" --optimize=1
+ cd "reg-gen-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
}
# vim:ts=2:sw=2:et: