summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcjayross2019-08-15 20:39:49 -0500
committercjayross2019-08-15 20:39:49 -0500
commit04f2e6ae236709bb8ee9ec87fb2297a652c83d06 (patch)
treec03e4a507312f933f8e364124b4ec664e762179f
downloadaur-04f2e6ae236709bb8ee9ec87fb2297a652c83d06.tar.gz
initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7a2d35cecf27
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-riccipy
+ pkgdesc = A Python3 symbolic calculator for General Relativity
+ pkgver = 0.1a0
+ pkgrel = 1
+ url = https://github.com/cjayross/riccipy
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-sympy
+ depends = python-numpy
+ depends = python-yaml
+ options = !emptydirs
+ source = https://github.com/cjayross/riccipy/archive/v0.1a0.tar.gz
+ sha256sums = f7f7e08f64fcaed60b346ac6a2523034354ffe09b3e9486e363ef140c6cb7e17
+
+pkgname = python-riccipy
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..194a3aacb149
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: cjayross <calvinjayross at gmail dot com>
+
+pkgname=python-riccipy
+pkgver=0.1a0
+pkgrel=1
+pkgdesc="A Python3 symbolic calculator for General Relativity"
+arch=("any")
+url="https://github.com/cjayross/riccipy"
+license=("MIT")
+depends=("python" "python-sympy" "python-numpy" "python-yaml")
+makedepends=("python-setuptools")
+options=("!emptydirs")
+source=("https://github.com/cjayross/riccipy/archive/v${pkgver}.tar.gz")
+sha256sums=("f7f7e08f64fcaed60b346ac6a2523034354ffe09b3e9486e363ef140c6cb7e17")
+
+package() {
+ cd "$srcdir/riccipy-${pkgver}"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -m 644 -D LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}