summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLubosz Sarnecki2015-06-22 22:58:07 +0200
committerLubosz Sarnecki2015-06-22 22:58:07 +0200
commit6eaa010b5f54922942f66fcdc180a5eb27ceddbc (patch)
tree01a4eba923db3b9ebe5de1cef1a56de6ec6fd0f7
downloadaur-python-rift-git.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD18
3 files changed, 51 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..073d324afec6
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = python-rift-git
+ pkgdesc = Python bindings for the Oculus Rift
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/lubosz/python-rift
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = python>=3.0
+ depends = cython
+ depends = openhmd-git
+ depends = oculus-udev
+ source = git+https://github.com/lubosz/python-rift.git
+
+pkgname = python-rift-git
+
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..250d720b26cd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-rift-git
+ pkgdesc = Python bindings for the Oculus Rift
+ pkgver = 1
+ pkgrel = 1
+ url = https://github.com/lubosz/python-rift
+ arch = i686
+ arch = x86_64
+ license = GPLv3
+ depends = python>=3.0
+ depends = cython
+ depends = openhmd-git
+ depends = oculus-udev
+ source = git+https://github.com/lubosz/python-rift.git
+ md5sums = SKIP
+
+pkgname = python-rift-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9532d44dc344
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Lubosz Sarnecki <lubosz@gmail.com>
+_realname=python-rift
+pkgname=$_realname-git
+pkgver=1
+pkgrel=1
+pkgdesc="Python bindings for the Oculus Rift"
+arch=('i686' 'x86_64')
+url="https://github.com/lubosz/python-rift"
+license=('GPLv3')
+depends=('python>=3.0' 'cython' 'openhmd-git' 'oculus-udev')
+source=("git+https://github.com/lubosz/$_realname.git")
+md5sums=('SKIP')
+
+package() {
+ cd $_realname
+ python setup.py install --root="$pkgdir" --optimize=1
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+}