summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWouter de Vries2015-11-23 11:58:06 +0100
committerWouter de Vries2015-11-23 11:58:06 +0100
commit9b72154c6237cf0681d3b840ac80713e6945a241 (patch)
treee5072ed79a3d88cac51489f35688d35cd5001e1b
downloadaur-9b72154c6237cf0681d3b840ac80713e6945a241.tar.gz
Initial commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD19
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..df6798b939b7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-ripe-atlas-cousteau
+ pkgdesc = A python wrapper around RIPE ATLAS API
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://github.com/RIPE-NCC/ripe-atlas-cousteau
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python>=3.4
+ depends = python-requests>=2.7.0
+ depends = python-dateutil,
+ depends = python-socketio-client>=0.6.5
+ provides = python-ripe-atlas-cousteau
+ source = https://pypi.python.org/packages/source/r/ripe.atlas.cousteau/ripe.atlas.cousteau-1.0.4.tar.gz
+ md5sums = 02534728feb8455b5de8e553480a0ece
+
+pkgname = python-ripe-atlas-cousteau
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f4c19e1cdb0a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Wouter de Vries <wouter@wouter-web.nl>
+_name=ripe.atlas.cousteau
+pkgname=python-ripe-atlas-cousteau
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="A python wrapper around RIPE ATLAS API"
+arch=('any')
+url="https://github.com/RIPE-NCC/ripe-atlas-cousteau"
+license=('GPL3')
+depends=('python>=3.4' 'python-requests>=2.7.0' 'python-dateutil', 'python-socketio-client>=0.6.5')
+makedepends=('python-setuptools')
+provides=('python-ripe-atlas-cousteau')
+source=("https://pypi.python.org/packages/source/r/$_name/$_name-$pkgver.tar.gz")
+md5sums=('02534728feb8455b5de8e553480a0ece')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1 || return 1
+}