summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus2016-01-18 19:39:50 -0200
committerMatheus2016-01-18 19:39:50 -0200
commit95ba29ebd77cd3bfdbf58c1c578eecb628e36908 (patch)
tree91e25e197e0877a5a030b23f68419959e7b3f1f2
parent8df09c975a7856f10acd360753a7d99acd82a8be (diff)
downloadaur-95ba29ebd77cd3bfdbf58c1c578eecb628e36908.tar.gz
Init
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD12
2 files changed, 11 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 55597fb33737..668ec0b8d634 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
# Generated by mksrcinfo v8
-# Sun Jan 17 17:59:14 UTC 2016
+# Mon Jan 18 21:38:30 UTC 2016
pkgbase = python-rivescript
pkgdesc = Rendering Intelligence Very Easily
pkgver = 1.0
@@ -10,7 +10,9 @@ pkgbase = python-rivescript
makedepends = git
depends = python2
depends = python-six
+ depends = python2-six
depends = python-setuptools
+ depends = python2-setuptools
source = git+https://github.com/aichaos/rivescript-python.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 0291fb170a90..f31606fdf708 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,11 +1,12 @@
# Maintainer: Trevor <assviolat0r at live dot com>
+
pkgname=python-rivescript
pkgver=1.0
pkgrel=1
pkgdesc="Rendering Intelligence Very Easily"
arch=('any')
license=('MIT')
-depends=('python2' 'python-six' 'python-setuptools')
+depends=('python2' 'python-six' 'python2-six' 'python-setuptools' 'python2-setuptools')
makedepends=('git')
url='https://github.com/aichaos/rivescript-python'
source=('git+https://github.com/aichaos/rivescript-python.git')
@@ -17,8 +18,11 @@ pkgver () {
echo $(git rev-list --count HEAD).$(git describe --always | sed 's/-/./g')
}
+build() {
+ python setup.py build
+}
+
package() {
- cd "$srcdir/$_gitname" # Git name and $pkgname differs
- # Do the actual installation
- python setup.py install --prefix=/usr --root="$_gitname" || return 1
+ cd "$srcdir/$_gitname"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 || return 1
}