summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2023-05-06 11:34:44 +0200
committerMassimiliano Torromeo2023-05-06 11:34:44 +0200
commite256a4cd6c2e408e9708d74124c353b78e0d39f8 (patch)
treeb7647ac4b073628eb3aa13a725c4db7ae23c13da
parentfb52963e9a35f00d88060115c32e3ea36dc4ba8b (diff)
downloadaur-e256a4cd6c2e408e9708d74124c353b78e0d39f8.tar.gz
Missing makedepends
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD3
2 files changed, 2 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c9992f071bab..aeafd9391eb1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -5,8 +5,7 @@ pkgbase = python-rmcl
url = https://github.com/rschroll/rmcl/
arch = any
license = MIT
- makedepends = python-build
- makedepends = python-installer
+ makedepends = python-poetry
makedepends = python-setuptools
makedepends = python-wheel
depends = python-trio
diff --git a/PKGBUILD b/PKGBUILD
index d3a0aefd220f..ce70d51c1d78 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,7 @@ arch=(any)
url="https://github.com/rschroll/rmcl/"
license=('MIT')
depends=('python-trio' 'python-asks')
-makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel')
+makedepends=('python-poetry' 'python-setuptools' 'python-wheel')
optdepends=('python-rmrl: producing PDF versions of any type of document with your annotations included')
source=("https://files.pythonhosted.org/packages/source/r/rmcl/rmcl-$pkgver.tar.gz"
"xdg.py::https://raw.githubusercontent.com/srstevenson/xdg/5.0.1/src/xdg/__init__.py")
@@ -30,5 +30,4 @@ package() {
# vendoring xdg.py due to conflicts with python-pyxdg
install -Dm0644 "$srcdir"/xdg.py "$pkgdir$_site_packages"/rmcl/xdg.py
- rm "$pkgdir$_site_packages"/rmcl-$pkgver-*.egg-info/requires.txt
}