summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Minnocci2021-04-05 23:05:54 +0200
committerFrancesco Minnocci2021-04-05 23:05:54 +0200
commite3a6c421d372b7bdcd71ee39bcf2fb3234eba257 (patch)
tree674f485b1e316e63dfe5dcec1703bddb35629736
parent9b8af76783d21e5ac3e02087861c290a63a77977 (diff)
downloadaur-e3a6c421d372b7bdcd71ee39bcf2fb3234eba257.tar.gz
Update depends() and remove nosetests (see PKGBUILD for the reason)
-rw-r--r--PKGBUILD21
1 files changed, 12 insertions, 9 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e40cf98fcb98..d5271001722b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,16 +1,17 @@
-# Maintainer: Aetf <aetf at unlimitedcodeworks dot xyz>
+# Maintainer: Francesco Minnocci <ascoli dot minnocci at gmail dot com>
+# Contributor: Aetf <aetf at unlimitedcodeworks dot xyz>
# Contributor: Glennie Vignarajah <glennie@glennie.fr>
pkgname=python-robobrowser
pkgver=0.5.3
-pkgrel=3
+pkgrel=4
pkgdesc="RoboBrowser is a simple, Pythonic library for browsing the web without a standalone web browser."
arch=('any')
url="https://github.com/jmcarp/robobrowser"
license=('MIT')
-depends=('python' 'python-requests' 'python-beautifulsoup4' 'python-pip' 'python-werkzeug' 'python-six')
+depends=('python' 'python-requests' 'python-beautifulsoup4' 'python-werkzeug' 'python-six')
makedepends=('python-setuptools')
-checkdepends=('python-nose')
+# checkdepends=('python-nose' 'python-mock' 'python-coverage' 'python-coveralls' 'python-docutils' 'python-sphinx')
source=("https://pypi.python.org/packages/source/r/robobrowser/robobrowser-$pkgver.tar.gz")
md5sums=('333ad401f4a0b320fa873c78bc5fb64d')
@@ -20,15 +21,17 @@ prepare() {
python setup.py build --quiet
}
-check() {
- cd "$srcdir/robobrowser-$pkgver"
- #python setup.py test -q
-}
+# check() {
+ # cd "$srcdir/robobrowser-$pkgver"
+
+ # nosetests ## TODO: Re-add tests when this gets fixed: https://github.com/jmcarp/robobrowser/issues/96
+# }
package() {
cd "$srcdir/robobrowser-$pkgver"
+
+ export PYTHONHASHSEED=0
python setup.py install --root="$pkgdir" --optimize=1
install -Dm644 README.rst "$pkgdir/usr/share/doc/$pkgname/README.rst"
}
-
# vim:set ts=2 sw=2 et: