summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Hanna2015-09-12 15:08:54 +0200
committerSimon Hanna2015-09-12 15:08:54 +0200
commit4a6aace91f9cc979696f43c6ad9af6c3a36b66fe (patch)
treebca681e9d7566e9748061f854d9e181168130a4f
downloadaur-4a6aace91f9cc979696f43c6ad9af6c3a36b66fe.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD28
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6c66379c52d5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-robot-detection
+ pkgdesc = Library for detecting if a HTTP User Agent header is likely to be a bot
+ pkgver = 0.3
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/robot-detection
+ arch = any
+ license = GPL
+ options = !emptydirs
+ source = https://pypi.python.org/packages/source/r/robot-detection/robot-detection-0.3.tar.gz
+ sha256sums = a5baf71cf69d95a167b6bd93e026bddd010d40adfc35bde02a61b651f61e6f47
+
+pkgname = python-robot-detection
+ depends = python
+
+pkgname = python2-robot-detection
+ depends = python2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4e775b0d2a8c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Simon Hanna <simon dot hanna AT serve-me DOT info>
+
+pkgname=('python-robot-detection' 'python2-robot-detection')
+_pkgbase='robot-detection'
+pkgver=0.3
+pkgrel=1
+pkgdesc="Library for detecting if a HTTP User Agent header is likely to be a bot"
+arch=(any)
+url="https://pypi.python.org/pypi/robot-detection"
+license=('GPL')
+options=(!emptydirs)
+install=
+source=("https://pypi.python.org/packages/source/r/robot-detection/robot-detection-${pkgver}.tar.gz")
+sha256sums=('a5baf71cf69d95a167b6bd93e026bddd010d40adfc35bde02a61b651f61e6f47')
+
+package_python-robot-detection() {
+ depends=('python')
+ cd "$srcdir/$_pkgbase-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+}
+
+package_python2-robot-detection() {
+ depends=('python2')
+ cd "$srcdir/$_pkgbase-$pkgver"
+ python2 setup.py install --root="$pkgdir/" --optimize=1
+}
+
+# vim:set ts=2 sw=2 et: