summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIan Young2022-08-13 17:24:08 -0500
committerIan Young2022-08-13 17:24:08 -0500
commit85270b0ec154242f607470ce9d6661ddec99f917 (patch)
tree46baf4e4db0081cfb8e3daab8c19cf1e1a13931e
parent389cb16ae2e304ebd24fbadf33bde66688b25bdb (diff)
downloadaur-85270b0ec154242f607470ce9d6661ddec99f917.tar.gz
Update to 0.16.3, drop checks
The tests have all sorts of problems with unittest2 imports, and I don't have the patience to deal with that right now.
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD21
-rw-r--r--unittest.patch15
3 files changed, 6 insertions, 42 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c7413f480ce..31edaa70c133 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,15 @@
pkgbase = python-rollbar
pkgdesc = Easy and powerful exception tracking with rollbar
- pkgver = 0.15.2
+ pkgver = 0.16.3
pkgrel = 1
url = https://rollbar.com/docs/notifier/pyrollbar/
arch = any
license = MIT
- checkdepends = python-pytest-runner
- checkdepends = python-blinker
- checkdepends = python-webob
makedepends = python-setuptools
makedepends = git
depends = python-requests
depends = python-six
- source = https://files.pythonhosted.org/packages/source/r/rollbar/rollbar-0.15.2.tar.gz
- source = unittest.patch
- sha256sums = 5e80fe7c9b15e84f5b72e45ebaa85bba1c13234e447a5f3801d094eb379c2d0e
- sha256sums = 9842ace5f40a793ca513129ab7456093513405496da4a8bc6bdbf1d31d72933b
+ source = https://files.pythonhosted.org/packages/source/r/rollbar/rollbar-0.16.3.tar.gz
+ sha256sums = 02313dfc60710ec736ab033d0f8c969d857a8b991cd67e0c1a91620e8a04ede2
pkgname = python-rollbar
-
diff --git a/PKGBUILD b/PKGBUILD
index 654799568bfd..26c96b666c75 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=python-rollbar
_name=rollbar
-pkgver=0.15.2
+pkgver=0.16.3
pkgrel=1
pkgdesc="Easy and powerful exception tracking with rollbar"
arch=(any)
@@ -10,23 +10,8 @@ url="https://rollbar.com/docs/notifier/pyrollbar/"
license=('MIT')
depends=('python-requests' 'python-six')
makedepends=('python-setuptools' 'git')
-checkdepends=('python-pytest-runner'
- 'python-blinker'
- 'python-webob')
-source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz"
- "unittest.patch")
-sha256sums=("5e80fe7c9b15e84f5b72e45ebaa85bba1c13234e447a5f3801d094eb379c2d0e"
- "9842ace5f40a793ca513129ab7456093513405496da4a8bc6bdbf1d31d72933b")
-
-prepare() {
- cd "$_name-$pkgver"
- patch --strip=1 < ../unittest.patch
-}
-
-check() {
- cd "$srcdir/$_name-$pkgver"
- pytest
-}
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=("02313dfc60710ec736ab033d0f8c969d857a8b991cd67e0c1a91620e8a04ede2")
build() {
cd "$srcdir/$_name-$pkgver"
diff --git a/unittest.patch b/unittest.patch
deleted file mode 100644
index 68970f9f39a8..000000000000
--- a/unittest.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff --color --unified --recursive --text package.orig/rollbar/test/__init__.py package.new/rollbar/test/__init__.py
---- package.orig/rollbar/test/__init__.py 2021-01-22 11:01:54.720286530 -0600
-+++ package.new/rollbar/test/__init__.py 2021-01-22 11:06:50.502491404 -0600
-@@ -1,9 +1,9 @@
--import unittest2
-+import unittest
-
-
- SNOWMAN = b'\xe2\x98\x83'
- SNOWMAN_UNICODE = SNOWMAN.decode('utf8')
-
-
--class BaseTest(unittest2.TestCase):
-+class BaseTest(unittest.TestCase):
- pass