summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMassimiliano Torromeo2016-08-15 10:23:37 +0200
committerMassimiliano Torromeo2016-08-15 10:23:37 +0200
commitd78b33e8b0d168b2198ab574882fc231f111204a (patch)
tree6d4f3a711f9722f300b19528de072a8e28b06cb1
downloadaur-d78b33e8b0d168b2198ab574882fc231f111204a.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--.gitignore17
-rw-r--r--PKGBUILD24
3 files changed, 58 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7f3a98b7249
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+# Generated by mksrcinfo v8
+# Sun Aug 14 18:12:39 UTC 2016
+pkgbase = python-rollbar
+ pkgdesc = Easy and powerful exception tracking with rollbar
+ pkgver = 0.13.3
+ pkgrel = 1
+ url = https://github.com/rollbar/pyrollbar
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-requests
+ depends = python-six
+ source = https://github.com/rollbar/pyrollbar/archive/v0.13.3/python-rollbar-0.13.3.tar.gz
+ sha256sums = e11b7927f68b5711498c4fd1e31e3c723916d1263d711fa735e182615a420651
+
+pkgname = python-rollbar
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9b97681014e9
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,17 @@
+*.zip
+*.jar
+*.tar
+*.tgz
+*.tbz2
+*.gz
+*.bz2
+*.xz
+*.gem
+*.run
+*.deb
+*.rpm
+*.sig
+*.log
+/src
+/pkg
+*.kate-swp
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c20b6926cab2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Massimiliano Torromeo <massimiliano.torromeo@gmail.com>
+
+pkgname=python-rollbar
+pkgver=0.13.3
+pkgrel=1
+pkgdesc="Easy and powerful exception tracking with rollbar"
+arch=(any)
+url="https://github.com/rollbar/pyrollbar"
+license=('MIT')
+depends=('python-requests' 'python-six')
+makedepends=('python-setuptools')
+source=("$url/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
+
+build() {
+ cd "$srcdir"/pyrollbar-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir"/pyrollbar-$pkgver
+ python setup.py install -O1 --skip-build --root="$pkgdir"
+}
+
+sha256sums=('e11b7927f68b5711498c4fd1e31e3c723916d1263d711fa735e182615a420651')