summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOliver Papst2017-11-18 19:00:17 +0100
committerOliver Papst2017-11-18 19:06:54 +0100
commitdb911b95e3e329acd0fc4657e15b120d7e0bff80 (patch)
tree32fb4343dc0d4c4218f78aa23cb0745edc982031
downloadaur-db911b95e3e329acd0fc4657e15b120d7e0bff80.tar.gz
Initial commit
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD41
2 files changed, 67 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a1aa81365e1
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = python-rootpy-git
+ pkgdesc = Pythonic interface with ROOT on top of the existing PyROOT bindings
+ pkgver = r3965.457e0740
+ pkgrel = 1
+ url = http://www.rootpy.org/
+ arch = any
+ license = BSD
+ makedepends = git
+ makedepends = python-setuptools
+ depends = python
+ depends = root
+ optdepends = python-numpy: Increase speed
+ optdepends = python-root_numpy: Increase speed
+ optdepends = python-matplotlib: Plotting
+ optdepends = python-pytables: HDF5 IO in rootpy.root2hdf5
+ optdepends = readline: Roosh (interactive root shell)
+ optdepends = python-termcolor: Roosh (interactive root shell)
+ optdepends = python-uncertainties: Uncertainties handeling
+ provides = python-rootpy
+ conflicts = python-rootpy
+ options = !emptydirs
+ source = git+https://github.com/rootpy/rootpy
+ sha256sums = SKIP
+
+pkgname = python-rootpy-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a24c491c31de
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Oliver Papst <opapst at ikp dot tu-darmstadt dot de>
+pkgname=python-rootpy-git
+pkgver=r3965.457e0740
+pkgrel=1
+pkgdesc="Pythonic interface with ROOT on top of the existing PyROOT bindings"
+arch=('any')
+url="http://www.rootpy.org/"
+license=('BSD')
+conflicts=('python-rootpy')
+provides=('python-rootpy')
+depends=('python'
+ 'root')
+makedepends=('git' 'python-setuptools')
+optdepends=('python-numpy: Increase speed'
+ 'python-root_numpy: Increase speed'
+ 'python-matplotlib: Plotting'
+ 'python-pytables: HDF5 IO in rootpy.root2hdf5'
+ 'readline: Roosh (interactive root shell)'
+ 'python-termcolor: Roosh (interactive root shell)'
+ 'python-uncertainties: Uncertainties handeling')
+#checkdepends=('python-nose')
+options=(!emptydirs)
+source=('git+https://github.com/rootpy/rootpy')
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/rootpy"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+#check() {
+# cd "${srcdir}/rootpy"
+# make test-code
+#}
+
+package() {
+ cd "${srcdir}/rootpy"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/"${pkgname}"/LICENSE
+}
+