summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSamir Benmendil2015-02-19 15:02:23 +0000
committerSamir Benmendil2015-02-19 15:02:23 +0000
commit99876cbb8df38b85dca988f345b65505e75e3bcb (patch)
treeb8cbcf8fc9a83b5651c6a089b894096a389fba01
downloadaur-99876cbb8df38b85dca988f345b65505e75e3bcb.tar.gz
python-rosdistro: add python3 + update
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD24
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bd56aea97d5c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-rosdistro
+ pkgdesc = A tool to work with rosdistro files
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = http://wiki.ros.org/rosdistro
+ arch = any
+ license = BSD, MIT
+ makedepends = python
+ depends = python
+ conflicts = python2-rosdistro
+ source = https://pypi.python.org/packages/source/r/rosdistro/rosdistro-0.4.1.tar.gz
+ md5sums = 722000b0872edabb55371c5ce964efd5
+
+pkgname = python-rosdistro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f573fd61920f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+#Automatically generated by pip2arch on 2014-06-09
+
+pkgname=python-rosdistro
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="A tool to work with rosdistro files"
+url="http://wiki.ros.org/rosdistro"
+depends=('python')
+makedepends=('python')
+license=('BSD, MIT')
+arch=('any')
+source=("https://pypi.python.org/packages/source/r/rosdistro/rosdistro-$pkgver.tar.gz")
+md5sums=('722000b0872edabb55371c5ce964efd5')
+conflicts=(python2-rosdistro)
+
+build() {
+ cd $srcdir/rosdistro-$pkgver
+ python setup.py build
+}
+
+package() {
+ cd $srcdir/rosdistro-$pkgver
+ python setup.py install --root="$pkgdir" --optimize=1
+}