summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKartik Mohta2020-05-31 11:22:14 -0700
committerKartik Mohta2020-05-31 11:22:14 -0700
commit7f3702325cfe68589f191ece2078a96899969cc5 (patch)
tree906176cb03f91d4a26c9af94bcf8c2846588bb3c
parente22cce3b259fff40769b6fe217b86460c48c535e (diff)
downloadaur-7f3702325cfe68589f191ece2078a96899969cc5.tar.gz
Switch source to github repo
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD21
2 files changed, 16 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a91d184cfe8e..1aefd7469954 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-rospkg
- pkgdesc = ROS package library
+ pkgdesc = Standalone Python library for the ROS package system
pkgver = 1.2.6
- pkgrel = 1
- url = http://wiki.ros.org/rospkg
+ pkgrel = 2
+ url = https://github.com/ros-infrastructure/rospkg
arch = any
license = BSD
makedepends = python-setuptools
@@ -11,8 +11,8 @@ pkgbase = python-rospkg
depends = python-distro
depends = python-yaml
conflicts = python2-rospkg
- source = https://files.pythonhosted.org/packages/source/r/rospkg/rospkg-1.2.6.tar.gz
- sha256sums = 3a27f5037afeba796449b30ad77cb1085fc65f8be10e75e40dbcc3777f83c1a6
+ source = https://github.com/ros-infrastructure/rospkg/archive/1.2.6.tar.gz
+ sha256sums = 6fec215df97895b3906660fed736544b7232635dd3a62e6a8aae553159e67ac2
pkgname = python-rospkg
diff --git a/PKGBUILD b/PKGBUILD
index 22bff5d1fb22..689b7c666a1e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,20 @@
# Maintainer: Kartik Mohta <kartikmohta@gmail.com>
-pkgbase='python-rospkg'
pkgname=('python-rospkg')
-_module='rospkg'
pkgver='1.2.6'
-pkgrel=1
-pkgdesc="ROS package library"
-url="http://wiki.ros.org/rospkg"
+pkgrel=2
+pkgdesc='Standalone Python library for the ROS package system'
+arch=('any')
+url='https://github.com/ros-infrastructure/rospkg'
+license=('BSD')
depends=('python' 'python-catkin_pkg' 'python-distro' 'python-yaml')
-conflicts=('python2-rospkg')
makedepends=('python-setuptools')
-license=('BSD')
-arch=('any')
-source=("https://files.pythonhosted.org/packages/source/${_module::1}/$_module/$_module-$pkgver.tar.gz")
-sha256sums=('3a27f5037afeba796449b30ad77cb1085fc65f8be10e75e40dbcc3777f83c1a6')
+
+conflicts=('python2-rospkg')
+source=("https://github.com/ros-infrastructure/rospkg/archive/${pkgver}.tar.gz")
+sha256sums=('6fec215df97895b3906660fed736544b7232635dd3a62e6a8aae553159e67ac2')
+
+_module='rospkg'
build() {
cd "${srcdir}/${_module}-${pkgver}"