summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrern2022-02-25 11:04:33 +0000
committerrern2022-02-25 11:04:33 +0000
commit25304f76e311aa85e4e1ccc21e201da853b2b620 (patch)
tree743920d3cf3901359ee7b9cf5f2eeb3fee02c3db
parent6de997ebb7c412b3e968ca781ad8294e6a2b6ead (diff)
downloadaur-25304f76e311aa85e4e1ccc21e201da853b2b620.tar.gz
update 0.7.1
-rw-r--r--.SRCINFO6
-rwxr-xr-xPKGBUILD14
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bcf953ff520d..2f2aedecc0bc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = python-rpi-gpio
pkgdesc = A Python module to control the GPIO on a Raspberry Pi
- pkgver = 0.7.1a4
+ pkgver = 0.7.1
pkgrel = 1
url = http://sourceforge.net/projects/raspberry-gpio-python
arch = any
license = MIT
makedepends = python-distribute
depends = python
- source = https://sourceforge.net/code-snapshots/hg/r/ra/raspberry-gpio-python/code/raspberry-gpio-python-code-08048dd1894a6b09a104557b6eaa6bb68b6baac5.zip
- sha256sums = aa6c4cfd22a485f19223ea468ec05f840ae1f9744dbb11ba5b106ff9bf33c164
+ source = https://github.com/rern/rern.github.io/releases/download/20210307/raspberry-gpio-python-0.7.1.tar.xz
+ sha256sums = c3c779fd4154d17c0c29303e926aa4831ad975967aa55c8e03b991519f2d465e
pkgname = python-rpi-gpio
diff --git a/PKGBUILD b/PKGBUILD
index 788c793de8da..d195ec1f5b76 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,11 @@
# Maintainer: rern <rernrern@gmail.com>
-# get pkgurl:
-# - https://sourceforge.net/p/raspberry-gpio-python/code/ci/default/tree/
-# - Download Snapshot > right-click "direct link" - Copy link address (must click once at least)
+# get srcurl: https://sourceforge.net/p/raspberry-gpio-python/code/ci/default/tree/ > Download Snapshot
-pkgurl=https://sourceforge.net/code-snapshots/hg/r/ra/raspberry-gpio-python/code/raspberry-gpio-python-code-08048dd1894a6b09a104557b6eaa6bb68b6baac5.zip
+srcurl=https://github.com/rern/rern.github.io/releases/download/20210307/raspberry-gpio-python-0.7.1.tar.xz
pkgname=python-rpi-gpio
-pkgver=0.7.1a4
+pkgver=0.7.1
pkgrel=1
pkgdesc="A Python module to control the GPIO on a Raspberry Pi"
url="http://sourceforge.net/projects/raspberry-gpio-python"
@@ -15,11 +13,11 @@ license=(MIT)
arch=(any)
depends=(python)
makedepends=(python-distribute)
-source=("$pkgurl")
-sha256sums=('aa6c4cfd22a485f19223ea468ec05f840ae1f9744dbb11ba5b106ff9bf33c164')
+source=("$srcurl")
+sha256sums=('c3c779fd4154d17c0c29303e926aa4831ad975967aa55c8e03b991519f2d465e')
package() {
- mv -f "$srcdir/$( basename $pkgurl .zip )" "$srcdir/RPi.GPIO-$pkgver"
+ mv -f "$srcdir/$( basename $srcurl .zip )" "$srcdir/RPi.GPIO-$pkgver"
cd "$srcdir/RPi.GPIO-$pkgver"
env CFLAGS="-fcommon" python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
}