summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjnanar2019-05-05 17:00:48 +0200
committerjnanar2019-05-05 17:00:48 +0200
commitee18e8b62c502be6721852bcbbf071608e4c4fd4 (patch)
tree23e21819341ee50a3cd764f6d3c0911865fbe489
downloadaur-ee18e8b62c502be6721852bcbbf071608e4c4fd4.tar.gz
initial commit: creation of python-rplidar package
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD39
2 files changed, 53 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4761d53727aa
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-rplidar-git
+ pkgdesc = Simple and lightweight module for working with RPLidar laser scanners
+ pkgver = 20170721
+ pkgrel = 1
+ url = https://github.com/SkoltechRobotics/rplidar.git
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python
+ conflicts = python-rplidar
+ options = !emptydirs
+
+pkgname = python-rplidar-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..e9e217291069
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Arnaud Joset <info@agayon.be>
+
+pkgname=python-rplidar-git
+pkgver=20170721
+pkgrel=1
+pkgdesc="Simple and lightweight module for working with RPLidar laser scanners"
+arch=(any)
+url="https://github.com/SkoltechRobotics/rplidar.git"
+license=('MIT')
+depends=('python')
+makedepends=('git')
+options=(!emptydirs)
+optdepends=('')
+
+conflicts=('python-rplidar')
+
+_gitroot="https://github.com/SkoltechRobotics/rplidar.git"
+_gitname="rplidar"
+
+
+package() {
+ cd "$srcdir"
+ msg "Connecting to GIT server...."
+
+ if [ -d $_gitname ] ; then
+ cd $_gitname && git pull origin
+ msg "The local files are updated."
+ else
+ git clone $_gitroot $_gitname
+ fi
+
+ msg "GIT checkout done or server timeout"
+
+ cd "$srcdir/$_gitname/"
+
+ # make sure UNICODE characters in the README are parsed correctly
+ export LC_CTYPE=en_US.utf-8
+ python setup.py install --root="$pkgdir/" --optimize=1
+}