summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorVladimir Gorbunov2015-06-12 16:27:01 +0300
committerVladimir Gorbunov2015-06-12 16:27:01 +0300
commit4a6f4443fee9c3f2789b3b1a5e6aa0035af3d71d (patch)
tree1731005f655eb340a9eef3cbb3606c8f43402ab2
downloadaur-4a6f4443fee9c3f2789b3b1a5e6aa0035af3d71d.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d4c725e38c5b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-rply-git
+ pkgdesc = A pure Python Lex/Yacc that works with RPython
+ pkgver = v0.7.3.r3.g700daa7
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/rply
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ provides = python-rply
+ options = !emptydirs
+ source = git+https://github.com/alex/rply.git
+ md5sums = SKIP
+
+pkgname = python-rply-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..51200ad07556
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Vladimir Gorbunov <truedaemon@gmail.com>
+pkgname=python-rply-git
+_gitname=rply
+pkgver=v0.7.3.r3.g700daa7
+pkgrel=1
+pkgdesc="A pure Python Lex/Yacc that works with RPython"
+arch=('any')
+url="https://pypi.python.org/pypi/rply"
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+options=(!emptydirs)
+provides=('python-rply')
+source=("git+https://github.com/alex/rply.git")
+md5sums=("SKIP")
+
+pkgver() {
+ cd "${_gitname}"
+ git describe --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "${_gitname}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}