summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPatrick Mischke2023-08-31 13:17:44 +0200
committerPatrick Mischke2023-08-31 13:18:57 +0200
commit6c61f2c8e5ab9fb36ee7d44b5b1fbc9150096b17 (patch)
treee643d2a6919af0edd6ca9bcf9373c399472a8ccb
downloadaur-6c61f2c8e5ab9fb36ee7d44b5b1fbc9150096b17.tar.gz
Initial commit
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD25
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52f1fc685e8d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-rsinstrument
+ pkgdesc = Convenient way of communicating with R&S instruments in python
+ pkgver = 1.55.0.99
+ pkgrel = 1
+ url = https://github.com/Rhode-Schwarz/RsInstrument
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python-pyvisa
+ source = https://github.com/Rohde-Schwarz/RsInstrument/archive/1d62deb1c662ce40290e427d4bebf835a7a78e6a.zip
+ sha256sums = 7437185a85665cfe6e97a751da8f366097bfabed5b0117e5b0a21accd0ed15b7
+
+pkgname = python-rsinstrument
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d053370f0de4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Contributor: Patrick Mischke
+
+pkgname='python-rsinstrument'
+_name='RsInstrument'
+pkgver=1.55.0.99
+_commit="1d62deb1c662ce40290e427d4bebf835a7a78e6a"
+pkgrel=1
+pkgdesc="Convenient way of communicating with R&S instruments in python"
+url="https://github.com/Rhode-Schwarz/RsInstrument"
+depends=('python-pyvisa')
+makedepends=('python-setuptools')
+license=('MIT')
+arch=('any')
+source=("https://github.com/Rohde-Schwarz/$_name/archive/$_commit.zip")
+sha256sums=('7437185a85665cfe6e97a751da8f366097bfabed5b0117e5b0a21accd0ed15b7')
+
+build() {
+ cd "$_name-$_commit"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$_commit"
+ python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+}