summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChristopher Arndt2019-11-24 18:26:31 +0100
committerChristopher Arndt2019-11-24 18:26:31 +0100
commitddc9d6aeb46b2bf6cb05b37f6aebd216271c3191 (patch)
treebf0fd317939def0e51ad5345d53c8f4e67e96e1b
parent1c949473399ac760398d78c013fd044b4b81b313 (diff)
downloadaur-ddc9d6aeb46b2bf6cb05b37f6aebd216271c3191.tar.gz
New upstream version 1.3.1
- Remove Python 2 package
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD42
2 files changed, 15 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a7ce79dad1c9..869f5b8e0c3a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,6 @@
pkgbase = python-rtmidi
- pkgver = 1.3.0
+ pkgdesc = Python bindings for the cross-platform MIDI I/O library RtMidi
+ pkgver = 1.3.1
pkgrel = 1
url = https://github.com/SpotlightKid/python-rtmidi
arch = i686
@@ -7,20 +8,11 @@ pkgbase = python-rtmidi
arch = arm
license = MIT
makedepends = cython
- makedepends = cython2
makedepends = python-setuptools
- makedepends = python2-setuptools
- depends = jack
- source = https://files.pythonhosted.org/packages/source/p/python-rtmidi/python-rtmidi-1.3.0.tar.gz
- sha256sums = 61e9d1c1f1202a1577f06644948af985427030984ff956970a22b50f080d4c2d
-
-pkgname = python-rtmidi
- pkgdesc = Python bindings for the cross-platform MIDI I/O library RtMidi
depends = jack
depends = python
+ source = https://files.pythonhosted.org/packages/source/p/python-rtmidi/python-rtmidi-1.3.1.tar.gz
+ sha256sums = f9d2a1b5374b2e6856006537b6d4d5ceed4db4c4ee60caec4af83707a78297e4
-pkgname = python2-rtmidi
- pkgdesc = Python 2 bindings for the cross-platform MIDI I/O library RtMidi
- depends = jack
- depends = python2
+pkgname = python-rtmidi
diff --git a/PKGBUILD b/PKGBUILD
index 1d8a12726a6b..90c34141c2b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,49 +1,27 @@
# Maintainer: Christopher Arndt <aur -at- chrisarndt -dot- de>
-_pkgbase="rtmidi"
-pkgbase="python-${_pkgbase}"
-pkgname=(${pkgbase} python2-${_pkgbase})
-pkgver=1.3.0
+pkgname="python-rtmidi"
+pkgdesc="Python bindings for the cross-platform MIDI I/O library RtMidi"
+pkgver=1.3.1
pkgrel=1
arch=('i686' 'x86_64' 'arm')
url="https://github.com/SpotlightKid/python-rtmidi"
license=('MIT')
-depends=('jack')
-makedepends=('cython' 'cython2' 'python-setuptools' 'python2-setuptools')
-source=("https://files.pythonhosted.org/packages/source/${pkgbase::1}/${pkgbase}/${pkgbase}-${pkgver}.tar.gz")
-sha256sums=('61e9d1c1f1202a1577f06644948af985427030984ff956970a22b50f080d4c2d')
+depends=('jack' 'python')
+makedepends=('cython' 'python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+sha256sums=('f9d2a1b5374b2e6856006537b6d4d5ceed4db4c4ee60caec4af83707a78297e4')
-prepare() {
- cp -r ${pkgbase}-${pkgver} python2-${_pkgbase}-${pkgver}
-}
-
build() {
- cd "${srcdir}/${pkgbase}-${pkgver}"
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py build
-
- cd "${srcdir}/python2-${_pkgbase}-${pkgver}"
- python2 setup.py build
}
-package_python-rtmidi() {
- pkgdesc="Python bindings for the cross-platform MIDI I/O library RtMidi"
- depends+=('python')
-
- cd "${srcdir}/${pkgbase}-${pkgver}"
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
python setup.py install --root="$pkgdir" --skip-build --optimize=1
# license
install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-package_python2-rtmidi() {
- pkgdesc="Python 2 bindings for the cross-platform MIDI I/O library RtMidi"
- depends+=('python2')
-
- cd "${srcdir}/python2-${_pkgbase}-$pkgver"
- python2 setup.py install --root="$pkgdir" --skip-build --optimize=1
-
- # license
- install -Dm644 LICENSE.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
-}