summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNils Steinger2017-08-10 15:58:27 +0200
committerNils Steinger2017-08-10 16:03:17 +0200
commit71cff92361dd167116886104a861028f972069c9 (patch)
tree97e8e6afe0657c6f849725e200a890d979e60e15
downloadaur-71cff92361dd167116886104a861028f972069c9.tar.gz
PKGBUILD based on Python-specific example from the wiki
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD19
2 files changed, 32 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f2654c094a86
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-rubymarshal
+ pkgdesc = Read and write serialized data from the Ruby Marshal library
+ pkgver = 1.0.3
+ pkgrel = 1
+ url = https://github.com/d9pouces/RubyMarshal
+ arch = any
+ license = custom:WTFPL
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/r/rubymarshal/rubymarshal-1.0.3.tar.gz
+ md5sums = df3c6b114637993adc5d3941c941f0d3
+
+pkgname = python-rubymarshal
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..898bcd9c7acf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Nils Steinger (voidptr.de)
+pkgname=python-rubymarshal
+_pkgname=rubymarshal
+pkgver=1.0.3
+pkgrel=1
+pkgdesc='Read and write serialized data from the Ruby Marshal library'
+url='https://github.com/d9pouces/RubyMarshal'
+arch=('any')
+license=('custom:WTFPL')
+depends=('python')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.tar.gz")
+md5sums=('df3c6b114637993adc5d3941c941f0d3')
+
+package() {
+ cd "$srcdir/$_pkgname-$pkgver"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ install -D -m644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+