summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryangon992020-11-17 22:07:19 +0800
committeryangon992020-11-17 22:07:19 +0800
commit8b60bb31405734a7954122ea337a163dda5e7ba0 (patch)
treeb1bbb4c5511b5484bcd4f5dc4a74aa66628a117b
downloadaur-8b60bb31405734a7954122ea337a163dda5e7ba0.tar.gz
init repo
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD31
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e1891aba2f98
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-runcommands
+ pkgdesc = Simple command/task runner that uses Python's standard library argparse under the hood
+ pkgver = 1.0a61
+ pkgrel = 1
+ url = https://github.com/wylee/runcommands
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ makedepends = python-setuptools
+ makedepends = flake8
+ makedepends = python-tox
+ depends = python-jinja
+ depends = python-pyaml
+ source = python-runcommands-1.0a61.tar.gz::https://github.com/wylee/runcommands/archive/1.0a61.tar.gz
+ sha512sums = 612ad156e66a3d3b9d2e8cd929c692dead8739bd8497d983ae588d039b6556c324273b160e553394fb2c558111b797e41f6ccc7d99edcf135022da4eae344b56
+
+pkgname = python-runcommands
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6023ef1ee8ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: yangon99 <yangon99_all@outlook.com>
+
+pkgname=python-runcommands
+pkgver=1.0a61
+pkgrel=1
+_appname=runcommands
+pkgdesc="Simple command/task runner that uses Python's standard library argparse under the hood"
+arch=('any')
+url="https://github.com/wylee/runcommands"
+license=('MIT')
+depends=('python-jinja' 'python-pyaml')
+makedepends=('python-setuptools' 'flake8' 'python-tox')
+checkdepends=('python-pytest')
+source=("$pkgname-$pkgver.tar.gz::https://github.com/wylee/runcommands/archive/$pkgver.tar.gz")
+sha512sums=('612ad156e66a3d3b9d2e8cd929c692dead8739bd8497d983ae588d039b6556c324273b160e553394fb2c558111b797e41f6ccc7d99edcf135022da4eae344b56')
+
+build() {
+ cd "$srcdir/$_appname-$pkgver"
+ python setup.py build
+}
+
+check() {
+ cd "$srcdir/$_appname-$pkgver"
+ pytest
+}
+
+package() {
+ cd "$srcdir/$_appname-$pkgver"
+ python3 setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}