summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorimlonghao2020-07-10 13:33:00 +0000
committerimlonghao2020-07-10 13:33:00 +0000
commit43b519c092e3e4447d1407341c784fdf796b59f8 (patch)
treede9fef154a376258b717731bc4a3eb5062e4846a
downloadaur-43b519c092e3e4447d1407341c784fdf796b59f8.tar.gz
New package
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 43 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2dace31b4c57
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = python-runlike
+ pkgdesc = Given an existing docker container, prints the command line necessary to run a copy of it
+ pkgver = 0.6.2
+ pkgrel = 1
+ url = https://github.com/lavie/runlike
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-click
+ source = https://files.pythonhosted.org/packages/source/r/runlike/runlike-0.6.2.tar.gz
+ source = https://github.com/lavie/runlike/raw/master/LICENSE.txt
+ sha256sums = da57e600cdadd3bb5ff1f7300e15ca8cb24a7e38a3d849c91f253c828791d3e1
+ sha256sums = 4daf3259296ec4d1725cb4a3061d1493e48abe29a83d9e0243298d90cd5dfe09
+
+pkgname = python-runlike
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..28997aadee38
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Hao Long <aur@esd.cc>
+
+pkgname=python-runlike
+_pkgname=runlike
+pkgver=0.6.2
+pkgrel=1
+pkgdesc="Given an existing docker container, prints the command line necessary to run a copy of it"
+arch=("any")
+url="https://github.com/lavie/runlike"
+license=('BSD')
+depends=('python-click')
+makedepends=('python-setuptools')
+source=("https://files.pythonhosted.org/packages/source/${_pkgname::1}/${_pkgname}/${_pkgname}-${pkgver}.tar.gz"
+ "${url}/raw/master/LICENSE.txt")
+sha256sums=('da57e600cdadd3bb5ff1f7300e15ca8cb24a7e38a3d849c91f253c828791d3e1'
+ '4daf3259296ec4d1725cb4a3061d1493e48abe29a83d9e0243298d90cd5dfe09')
+
+build() {
+ cd ${_pkgname}-${pkgver}
+ python setup.py build
+}
+
+package() {
+ cd ${_pkgname}-${pkgver}
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm644 ${srcdir}/LICENSE.txt ${pkgdir}/usr/share/licenses/${pkgname}/LICENSE.txt
+}