summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKlaus Alexander Seistrup2021-11-25 10:15:44 +0100
committerKlaus Alexander Seistrup2021-11-25 10:15:44 +0100
commit7175a7d662aaa436504088e06f821ce1e97a25fa (patch)
treed0393510117a4748b883ae49d7ce4bd71aac94d5
parent0ac1927a4216a7e429f8e7aaa0f5995f471e755b (diff)
downloadaur-7175a7d662aaa436504088e06f821ce1e97a25fa.tar.gz
python-runtype-0.2.4-2: add python-setuptools to makedepends
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5a647d5b652f..2ddf32ae50b8 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = python-runtype
pkgdesc = Python utilities for run-time type validation and multiple dispatch
pkgver = 0.2.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/erezsh/runtype
arch = any
license = MIT
- makedepends = python-sphinx
makedepends = python-recommonmark
+ makedepends = python-setuptools
+ makedepends = python-sphinx
makedepends = python-sphinx-markdown-tables
depends = python
source = https://github.com/erezsh/runtype/archive/refs/tags/0.2.4.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 4690f8f609dd..588c38a1b4d3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# -*- sh -*-
pkgname='python-runtype'
-_pkgname=${pkgname#python-}
+_pkgname=${pkgname##python-}
pkgver=0.2.4
-pkgrel=1
+pkgrel=2
pkgdesc='Python utilities for run-time type validation and multiple dispatch'
arch=('any')
license=('MIT')
@@ -12,8 +12,9 @@ url='https://github.com/erezsh/runtype'
source=("$url/archive/refs/tags/${pkgver}.tar.gz")
depends=('python')
makedepends=(
- 'python-sphinx'
'python-recommonmark'
+ 'python-setuptools'
+ 'python-sphinx'
'python-sphinx-markdown-tables'
)
md5sums=(
@@ -42,7 +43,7 @@ build() {
package() {
cd "$srcdir/$_pkgname-$pkgver" || exit 1
- python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1
+ python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1 --skip-build
install -Dm0644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"