summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorIlya Elenskiy2018-07-09 17:44:53 +0200
committerIlya Elenskiy2018-07-09 17:44:53 +0200
commit44017ad517b133c33768f8794165dc34aaeb4e71 (patch)
tree96d5dd5f4e590d2fb8f476f84dbb1fa04b806e2a
downloadaur-44017ad517b133c33768f8794165dc34aaeb4e71.tar.gz
initial: 1.6.1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD24
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..94626305c5c3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-rx
+ pkgdesc = The Reactive Extensions for Python (RxPY)
+ pkgver = 1.6.1
+ pkgrel = 1
+ url = http://reactivex.io
+ arch = any
+ license = apache
+ makedepends = python-setuptools
+ source = rx::git+https://github.com/ReactiveX/RxPY.git#tag=1.6.1
+ md5sums = SKIP
+
+pkgname = python-rx
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..577885e4fb19
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Ilya Elenskiy <elenskiy.ilya[@]gmail[.]com>
+
+pkgname=python-rx
+_name=rx
+pkgver=1.6.1
+pkgrel=1
+pkgdesc="The Reactive Extensions for Python (RxPY)"
+arch=('any')
+url='http://reactivex.io'
+license=('apache')
+makedepends=( 'python-setuptools' )
+source=("rx::git+https://github.com/ReactiveX/RxPY.git#tag=${pkgver}")
+md5sums=('SKIP')
+
+
+build() {
+ cd "${srcdir}/${_name}"
+ python setup.py build
+}
+
+package() {
+ cd "${srcdir}/${_name}"
+ python setup.py install --root="${pkgdir}/" --optimize=1 --skip-build
+}