summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2022-05-16 15:13:35 -0400
committerBuildTools2022-05-16 15:13:35 -0400
commit55136a603d455ba72a015eec006afc0d0b048468 (patch)
treeb0c3800d67e1c00a8f4e005cde4d68102113e0dd
parent5c1b6e66a434797f9148d80c016b57320a4aa623 (diff)
downloadaur-55136a603d455ba72a015eec006afc0d0b048468.tar.gz
fixed build
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a77fd2c7c826..b4e6b07d76e6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-rxv
pkgdesc = Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers.
pkgver = 0.7.0
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/wuub/rxv
arch = any
license = BSD
checkdepends = python
- makedepends = python-setuptools
+ makedepends = python-build
+ makedepends = python-installer
+ makedepends = python-wheel
depends = python-defusedxml
- source = https://github.com/wuub/rxv/archive/refs/tags/v0.7.0.tar.gz
- sha256sums = 957dce69a2304d087c5fd9cd4c400b41efc1fc7579d3644a873877d32f09df43
+ source = https://files.pythonhosted.org/packages/source/r/rxv/rxv-0.7.0.tar.gz
+ sha256sums = 6e21f6e5e808ed28147633633b1073f22f30ed84cf47868d970598cefe2b98a9
pkgname = python-rxv
diff --git a/PKGBUILD b/PKGBUILD
index 1126e73c42ad..e642d11537a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,27 @@
# Maintainer: Jameson Pugh <imntreal@gmail.com>
-pkgbase=python-rxv
pkgname=python-rxv
+_name=rxv
pkgver=0.7.0
-pkgrel=1
+pkgrel=2
pkgdesc="Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers."
arch=('any')
url='https://github.com/wuub/rxv'
license=('BSD')
depends=('python-defusedxml')
-makedepends=('python-setuptools')
+makedepends=('python-build' 'python-installer' 'python-wheel')
checkdepends=('python')
-source=("https://github.com/wuub/rxv/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('957dce69a2304d087c5fd9cd4c400b41efc1fc7579d3644a873877d32f09df43')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('6e21f6e5e808ed28147633633b1073f22f30ed84cf47868d970598cefe2b98a9')
-check() {
+build() {
cd "${srcdir}/rxv-${pkgver}"
- python setup.py test
+ python -m build --wheel --no-isolation
}
package() {
cd "${srcdir}/rxv-${pkgver}"
- python setup.py install --root=${pkgdir}
+ python -m installer --destdir=${pkgdir} dist/*.whl
}
# vim:set ts=2 sw=2 et: