summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2022-02-04 15:23:50 -0500
committerBuildTools2022-02-04 15:23:50 -0500
commit5c1b6e66a434797f9148d80c016b57320a4aa623 (patch)
tree1aa8c29d91ffeb552fe09a8813cccff02e54635a
parente1aec33f48f2cd40eafb3579625b39d43f325aa2 (diff)
downloadaur-5c1b6e66a434797f9148d80c016b57320a4aa623.tar.gz
0.7.0
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD27
2 files changed, 12 insertions, 31 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd43a0f8a4ed..a77fd2c7c826 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,22 +1,14 @@
pkgbase = python-rxv
pkgdesc = Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers.
- pkgver = 0.6.0
+ pkgver = 0.7.0
pkgrel = 1
url = https://github.com/wuub/rxv
arch = any
license = BSD
checkdepends = python
- checkdepends = python2
makedepends = python-setuptools
- makedepends = python2-setuptools
- source = https://files.pythonhosted.org/packages/67/01/f2c35d41cbef0e236122572da177d4684fa0a924e521538c194b020729dc/rxv-0.6.0.tar.gz
- sha256sums = aa1d707fb4f6d71581aca9a864fb03e62f001b32c835b72ddba5cfdb5c3a661f
-
-pkgname = python-rxv
- pkgdesc = Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers. (python3 version)
depends = python-defusedxml
+ source = https://github.com/wuub/rxv/archive/refs/tags/v0.7.0.tar.gz
+ sha256sums = 957dce69a2304d087c5fd9cd4c400b41efc1fc7579d3644a873877d32f09df43
-pkgname = python2-rxv
- pkgdesc = Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers. (python2 version)
- depends = python2-defusedxml
-
+pkgname = python-rxv
diff --git a/PKGBUILD b/PKGBUILD
index 60e30939eec7..1126e73c42ad 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,38 +1,27 @@
# Maintainer: Jameson Pugh <imntreal@gmail.com>
pkgbase=python-rxv
-pkgname=('python-rxv' 'python2-rxv')
-pkgver=0.6.0
+pkgname=python-rxv
+pkgver=0.7.0
pkgrel=1
pkgdesc="Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers."
arch=('any')
url='https://github.com/wuub/rxv'
license=('BSD')
-makedepends=('python-setuptools' 'python2-setuptools')
-checkdepends=('python' 'python2')
-source=("https://files.pythonhosted.org/packages/67/01/f2c35d41cbef0e236122572da177d4684fa0a924e521538c194b020729dc/rxv-${pkgver}.tar.gz")
-sha256sums=('aa1d707fb4f6d71581aca9a864fb03e62f001b32c835b72ddba5cfdb5c3a661f')
+depends=('python-defusedxml')
+makedepends=('python-setuptools')
+checkdepends=('python')
+source=("https://github.com/wuub/rxv/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('957dce69a2304d087c5fd9cd4c400b41efc1fc7579d3644a873877d32f09df43')
check() {
cd "${srcdir}/rxv-${pkgver}"
python setup.py test
- python2 setup.py test
}
-package_python-rxv() {
- depends=('python-defusedxml')
- pkgdesc="Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers. (python3 version)"
-
+package() {
cd "${srcdir}/rxv-${pkgver}"
python setup.py install --root=${pkgdir}
}
-package_python2-rxv() {
- depends=('python2-defusedxml')
- pkgdesc="Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers. (python2 version)"
-
- cd "${srcdir}/rxv-${pkgver}"
- python2 setup.py install --root=${pkgdir}
-}
-
# vim:set ts=2 sw=2 et: