summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBuildTools2018-10-07 15:57:50 -0400
committerBuildTools2018-10-07 15:57:50 -0400
commite1aec33f48f2cd40eafb3579625b39d43f325aa2 (patch)
treed7a50a28f4c049f69473ec8026d111da640321a5
downloadaur-e1aec33f48f2cd40eafb3579625b39d43f325aa2.tar.gz
initial commit
-rw-r--r--.SRCINFO22
-rw-r--r--PKGBUILD38
2 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd43a0f8a4ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,22 @@
+pkgbase = python-rxv
+ pkgdesc = Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers.
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/wuub/rxv
+ arch = any
+ license = BSD
+ checkdepends = python
+ checkdepends = python2
+ makedepends = python-setuptools
+ makedepends = python2-setuptools
+ source = https://files.pythonhosted.org/packages/67/01/f2c35d41cbef0e236122572da177d4684fa0a924e521538c194b020729dc/rxv-0.6.0.tar.gz
+ sha256sums = aa1d707fb4f6d71581aca9a864fb03e62f001b32c835b72ddba5cfdb5c3a661f
+
+pkgname = python-rxv
+ pkgdesc = Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers. (python3 version)
+ depends = python-defusedxml
+
+pkgname = python2-rxv
+ pkgdesc = Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers. (python2 version)
+ depends = python2-defusedxml
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..60e30939eec7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Jameson Pugh <imntreal@gmail.com>
+
+pkgbase=python-rxv
+pkgname=('python-rxv' 'python2-rxv')
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers."
+arch=('any')
+url='https://github.com/wuub/rxv'
+license=('BSD')
+makedepends=('python-setuptools' 'python2-setuptools')
+checkdepends=('python' 'python2')
+source=("https://files.pythonhosted.org/packages/67/01/f2c35d41cbef0e236122572da177d4684fa0a924e521538c194b020729dc/rxv-${pkgver}.tar.gz")
+sha256sums=('aa1d707fb4f6d71581aca9a864fb03e62f001b32c835b72ddba5cfdb5c3a661f')
+
+check() {
+ cd "${srcdir}/rxv-${pkgver}"
+ python setup.py test
+ python2 setup.py test
+}
+
+package_python-rxv() {
+ depends=('python-defusedxml')
+ pkgdesc="Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers. (python3 version)"
+
+ cd "${srcdir}/rxv-${pkgver}"
+ python setup.py install --root=${pkgdir}
+}
+
+package_python2-rxv() {
+ depends=('python2-defusedxml')
+ pkgdesc="Automation Library for Yamaha RX-V473, RX-V573, RX-V673, RX-V773 receivers. (python2 version)"
+
+ cd "${srcdir}/rxv-${pkgver}"
+ python2 setup.py install --root=${pkgdir}
+}
+
+# vim:set ts=2 sw=2 et: