summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorenvolution2024-12-18 10:54:21 -0500
committerenvolution2024-12-18 10:54:21 -0500
commit60c6d51498686e5d9535aad985e546b9868396f0 (patch)
tree6ead9c1b3ea1734864d7482d4890fde92eb78fc7
parent964d2f1fe7eb9c101dc71eb1471f00dda2ce6760 (diff)
downloadaur-60c6d51498686e5d9535aad985e546b9868396f0.tar.gz
try solve mysterious check failure reported by a user and add to ci
-rw-r--r--.SRCINFO5
-rw-r--r--.nvchecker.toml3
-rw-r--r--PKGBUILD58
3 files changed, 37 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8392e824fbb..fbf0dfea2e22 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,10 @@
pkgbase = python-safetensors
pkgdesc = Simple, safe way to store and distribute tensors
pkgver = 0.4.5
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/huggingface/safetensors
arch = x86_64
- license = Apache
+ license = Apache-2.0
checkdepends = python-pytorch
checkdepends = python-numpy
checkdepends = python-tensorflow
@@ -18,6 +18,7 @@ pkgbase = python-safetensors
checkdepends = python-huggingface-hub
checkdepends = python-pytest
checkdepends = python-pytest-benchmark
+ checkdepends = python-hypothesis
checkdepends = python-h5py
makedepends = python-build
makedepends = python-installer
diff --git a/.nvchecker.toml b/.nvchecker.toml
new file mode 100644
index 000000000000..8f1bbe426838
--- /dev/null
+++ b/.nvchecker.toml
@@ -0,0 +1,3 @@
+[python-safetensors]
+source="pypi"
+pypi="safetensors"
diff --git a/PKGBUILD b/PKGBUILD
index 64ae56e3c6fb..55da25afb884 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,40 +1,43 @@
-# Maintainer: Andrea Manenti <andrea [dot] manenti [at] yahoo [dot] com>
+# Maintainer: envolution
+# Contributor: Andrea Manenti <andrea [dot] manenti [at] yahoo [dot] com>
# Contributor: Henry-ZHR <henry-zhr@qq.com>
+# shellcheck shell=bash disable=SC2034,SC2154
pkgname=python-safetensors
pkgver=0.4.5
-pkgrel=1
+pkgrel=2
pkgdesc='Simple, safe way to store and distribute tensors'
arch=('x86_64')
url='https://github.com/huggingface/safetensors'
-license=('Apache')
+license=('Apache-2.0')
depends=('python')
makedepends=('python-build'
- 'python-installer'
- 'python-maturin'
- 'python-wheel'
- 'python-setuptools-rust')
+ 'python-installer'
+ 'python-maturin'
+ 'python-wheel'
+ 'python-setuptools-rust')
optdepends=('python-jax'
- 'python-flax'
- 'python-jaxlib'
- 'python-numpy'
- 'python-paddlepaddle'
- 'python-tensorflow'
- 'python-pytorch')
+ 'python-flax'
+ 'python-jaxlib'
+ 'python-numpy'
+ 'python-paddlepaddle'
+ 'python-tensorflow'
+ 'python-pytorch')
checkdepends=('python-pytorch'
- 'python-numpy'
- 'python-tensorflow'
- 'python-jax'
- 'python-flax'
- 'python-jaxlib'
- # 'python-paddlepaddle'
- 'python-black'
- 'python-isort'
- 'flake8'
- 'python-click'
- 'python-huggingface-hub'
- 'python-pytest'
- 'python-pytest-benchmark'
- 'python-h5py')
+ 'python-numpy'
+ 'python-tensorflow'
+ 'python-jax'
+ 'python-flax'
+ 'python-jaxlib'
+ # 'python-paddlepaddle'
+ 'python-black'
+ 'python-isort'
+ 'flake8'
+ 'python-click'
+ 'python-huggingface-hub'
+ 'python-pytest'
+ 'python-pytest-benchmark'
+ 'python-hypothesis'
+ 'python-h5py')
source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/refs/tags/v${pkgver}.tar.gz")
sha256sums=('31066e251e7aaf75decdc7bae7a819d7648de648972fc7b3aee1e181ab1ca9e8')
@@ -64,3 +67,4 @@ package() {
cd "safetensors-${pkgver}/bindings/python"
python -m installer --destdir="${pkgdir}" dist/*.whl
}
+# vim:set ts=2 sw=2 et: