summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorclintval2018-01-06 12:14:32 -0500
committerclintval2018-01-06 12:14:32 -0500
commitf577f95c75f892045fc0bcb3e03bccac37aa4e05 (patch)
treec33523afdc4c871753b34dc621cb0288e56da6ad
downloadaur-python-sample-sheet.tar.gz
First commit with PKGBUILD and .SRCINFO
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD28
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0a8d502232ae
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = python-sample-sheet
+ pkgdesc = A bioinformatics Illumina Sample Sheet parsing utility
+ pkgver = 0.1.1
+ pkgrel = 1
+ url = https://pypi.python.org/pypi/sample_sheet
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-click
+ depends = python-smart-open
+ depends = python-tabulate
+ depends = python-terminaltables
+ provides = python-sample-sheet
+ conflicts = python-sample-sheet
+ options = !emptydirs
+ source = https://pypi.python.org/packages/fd/98/fc423199c66c513773a1394828a5e3b599bc4492f79fae087e92f01eb1d5/sample_sheet-0.1.1.tar.gz
+ md5sums = daf3355933d0763223b4e99c2a7bc24d
+
+pkgname = python-sample-sheet
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01d5eaebb387
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Clint Valentine <valentine.clint@gmail.com>
+
+pkgname='python-sample-sheet'
+pkgver=0.1.1
+pkgrel=1
+pkgdesc="A bioinformatics Illumina Sample Sheet parsing utility"
+arch=('any')
+url="https://pypi.python.org/pypi/sample_sheet"
+license=('MIT')
+depends=(
+ 'python'
+ 'python-click'
+ 'python-smart-open'
+ 'python-tabulate'
+ 'python-terminaltables'
+)
+makedepends=('python-setuptools')
+optdepends=()
+provides=('python-sample-sheet')
+conflicts=('python-sample-sheet')
+options=(!emptydirs)
+source=("https://pypi.python.org/packages/fd/98/fc423199c66c513773a1394828a5e3b599bc4492f79fae087e92f01eb1d5/sample_sheet-0.1.1.tar.gz")
+md5sums=('daf3355933d0763223b4e99c2a7bc24d')
+
+package() {
+ cd "${srcdir}/sample_sheet-${pkgver}"
+ python setup.py install --root="${pkgdir}/" --optimize=1
+}