summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarlwgeorge2017-04-13 21:59:02 -0500
committercarlwgeorge2017-04-13 21:59:02 -0500
commit003c28f260359ac9e0b63785f40be0f9682f87cf (patch)
treee4ee7c35eda20118913d9680c0d461ac421229e9
parent05cce175040c358af13ec7a2fd3022ca14e79830 (diff)
downloadaur-003c28f260359ac9e0b63785f40be0f9682f87cf.tar.gz
0.5.0-1
* add python-websockets dependency
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore11
-rw-r--r--PKGBUILD7
3 files changed, 18 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 50f94d7141d6..4f59ac88e19f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,16 @@
# Generated by mksrcinfo v8
-# Thu Mar 2 23:45:30 UTC 2017
+# Fri Apr 14 02:54:42 UTC 2017
pkgbase = python-sanic
pkgdesc = A microframework based on uvloop, httptools, and learnings of flask
- pkgver = 0.4.1
+ pkgver = 0.5.0
pkgrel = 1
url = https://github.com/channelcat/sanic
arch = any
license = MIT
makedepends = python-setuptools
- source = https://files.pythonhosted.org/packages/source/s/sanic/sanic-0.4.1.tar.gz
- source = https://raw.githubusercontent.com/channelcat/sanic/0.4.1/LICENSE
- sha256sums = b87393002894a539174a0037c0f6293a558ff393d305c20fa07829f1757360a1
+ source = https://files.pythonhosted.org/packages/source/s/sanic/sanic-0.5.0.tar.gz
+ source = https://raw.githubusercontent.com/channelcat/sanic/0.5.0/LICENSE
+ sha256sums = 594fa5c1d7812a1114b4049a9ff53a167f7d929d4bf05b2e23f5619861e6e747
sha256sums = a406579cd136771c705c521db86ca7d60a6f3de7c9b5460e6193a2df27861bde
pkgname = python-sanic
@@ -18,4 +18,5 @@ pkgname = python-sanic
depends = python-httptools>=0.0.9
depends = python-ujson>=1.35
depends = python-aiofiles>=0.3.0
+ depends = python-websockets>=3.2
diff --git a/.gitignore b/.gitignore
index f98512bb47e1..cb20ebe4ea4a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,6 +1,11 @@
+# sources
*.tar.gz
-*.pkg.tar.xz
+LICENSE
+
+# build logs
*-build.log
-*-package.log
*-namcap.log
-LICENSE
+*-package*.log
+
+# packages
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
index 4044e2c24297..620d459876d0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_name="sanic"
pkgname="python-$_name"
-pkgver=0.4.1
+pkgver=0.5.0
pkgrel=1
pkgdesc="A microframework based on uvloop, httptools, and learnings of flask"
arch=("any")
@@ -11,7 +11,7 @@ license=("MIT")
makedepends=("python-setuptools")
source=("https://files.pythonhosted.org/packages/source/${_name:0:1}/$_name/$_name-$pkgver.tar.gz"
"https://raw.githubusercontent.com/channelcat/sanic/$pkgver/LICENSE")
-sha256sums=('b87393002894a539174a0037c0f6293a558ff393d305c20fa07829f1757360a1'
+sha256sums=('594fa5c1d7812a1114b4049a9ff53a167f7d929d4bf05b2e23f5619861e6e747'
'a406579cd136771c705c521db86ca7d60a6f3de7c9b5460e6193a2df27861bde')
build() {
@@ -23,7 +23,8 @@ package() {
depends=("python-uvloop>=0.5.3"
"python-httptools>=0.0.9"
"python-ujson>=1.35"
- "python-aiofiles>=0.3.0")
+ "python-aiofiles>=0.3.0"
+ "python-websockets>=3.2")
cd "$_name-$pkgver"
python setup.py install --skip-build --root="$pkgdir" --optimize=1
install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" "$srcdir/LICENSE"