summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcarlwgeorge2017-01-28 12:09:32 -0600
committercarlwgeorge2017-01-28 12:09:32 -0600
commiteb091ec64147639e77410a7092b0e4d822565328 (patch)
tree69bf71b848d470bd9d40a91b9bbddf51681161a6
parent0958bd6ff023651820931d8bb16b706a6a6ad031 (diff)
downloadaur-eb091ec64147639e77410a7092b0e4d822565328.tar.gz
0.3.0-1
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD21
2 files changed, 14 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 66b41e2db9f0..30c1b6f404bf 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,19 @@
# Generated by mksrcinfo v8
-# Sat Jan 14 22:12:11 UTC 2017
+# Sat Jan 28 18:02:12 UTC 2017
pkgbase = python-sanic
pkgdesc = A microframework based on uvloop, httptools, and learnings of flask
- pkgver = 0.2.0
+ pkgver = 0.3.0
pkgrel = 1
url = https://github.com/channelcat/sanic
arch = any
license = MIT
makedepends = python-setuptools
- source = https://github.com/channelcat/sanic/archive/0.2.0.tar.gz
- sha256sums = eda329ee2d4894e1564e40152203532291bec7ac764005946619825aaeee2985
+ source = https://github.com/channelcat/sanic/archive/0.3.0.tar.gz
+ sha256sums = bee1f2df2494af386085d8d4767de5d8c817b706d987faa57c29a527995e393f
pkgname = python-sanic
depends = python-uvloop>=0.5.3
depends = python-httptools>=0.0.9
depends = python-ujson>=1.35
depends = python-aiofiles>=0.3.0
- depends = python-multidict>=2.0
diff --git a/PKGBUILD b/PKGBUILD
index 18b8058baccf..00ade7e3e94c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Carl George < arch at cgtx dot us >
_name="sanic"
-pkgname="python-${_name}"
-pkgver="0.2.0"
-pkgrel="1"
+pkgname="python-$_name"
+pkgver=0.3.0
+pkgrel=1
pkgdesc="A microframework based on uvloop, httptools, and learnings of flask"
arch=("any")
url="https://github.com/channelcat/sanic"
license=("MIT")
makedepends=("python-setuptools")
-source=("https://github.com/channelcat/sanic/archive/${pkgver}.tar.gz")
-sha256sums=('eda329ee2d4894e1564e40152203532291bec7ac764005946619825aaeee2985')
+source=("https://github.com/channelcat/sanic/archive/$pkgver.tar.gz")
+sha256sums=('bee1f2df2494af386085d8d4767de5d8c817b706d987faa57c29a527995e393f')
build() {
- cd "${srcdir}/${_name}-${pkgver}"
+ cd "$_name-$pkgver"
python setup.py build
}
@@ -21,9 +21,8 @@ package() {
depends=("python-uvloop>=0.5.3"
"python-httptools>=0.0.9"
"python-ujson>=1.35"
- "python-aiofiles>=0.3.0"
- "python-multidict>=2.0")
- cd "${srcdir}/${_name}-${pkgver}"
- python setup.py install --skip-build --root="${pkgdir}" --optimize=1
- install -Dm0644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ "python-aiofiles>=0.3.0")
+ cd "$_name-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -D --mode 644 --target-directory "$pkgdir/usr/share/licenses/$pkgname" LICENSE
}