summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorQirui Wang2021-03-21 10:39:22 -0400
committerQirui Wang2021-03-21 10:39:22 -0400
commit04083022d03e02710bf1cb2cf5b7c82c824c22a4 (patch)
tree71907acd8888a662149034679fd99a2c437ce452
downloadaur-04083022d03e02710bf1cb2cf5b7c82c824c22a4.tar.gz
v0.4.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD29
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1815ea6520d8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = python-sanic-routing
+ pkgdesc = Internal handler routing for Sanic beginning with v21.3.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://sanicframework.org/
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ source = https://github.com/sanic-org/sanic-router/archive/v0.4.0.tar.gz
+ source = https://github.com/sanic-org/sanic/raw/v21.3.1/LICENSE
+ sha256sums = 47c578b25c05f6b02c84d7b650ef5004199908b8bafe7da1e46a6cbf662ee53e
+ sha256sums = cdc294c495a8d80f3fb596f257fb7b61214c7d5e5ee254852b753ff81e8e137c
+
+pkgname = python-sanic-routing
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..66610ea54206
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Qirui Wang <wqr.prg@gmail.com>
+# Contributor: Carl George < arch at cgtx dot us >
+
+_name="sanic-router"
+pkgname="python-sanic-routing"
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='Internal handler routing for Sanic beginning with v21.3.'
+arch=("any")
+url='https://sanicframework.org/'
+license=("MIT")
+makedepends=("python-setuptools")
+source=(
+ "https://github.com/sanic-org/${_name}/archive/v${pkgver}.tar.gz"
+ "https://github.com/sanic-org/sanic/raw/v21.3.1/LICENSE"
+)
+sha256sums=('47c578b25c05f6b02c84d7b650ef5004199908b8bafe7da1e46a6cbf662ee53e'
+ 'cdc294c495a8d80f3fb596f257fb7b61214c7d5e5ee254852b753ff81e8e137c')
+
+build() {
+ cd "$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$_name-$pkgver"
+ python setup.py install --skip-build --root="$pkgdir" --optimize=1
+ install -Dm644 "$srcdir/LICENSE" "$pkgdir/usr/share/licenses/$pkgname/licence"
+}