summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJoseph Diza2022-05-07 03:00:18 -0700
committerJoseph Diza2022-05-07 03:00:18 -0700
commitaf9a38a068e07a8cb330208eaf1ee9c801522e13 (patch)
tree675d6d2003a3ebeb8dd458cd0e45dfb3329d0a40
downloadaur-af9a38a068e07a8cb330208eaf1ee9c801522e13.tar.gz
Initial PKGBUILD for python-sapply-git
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD24
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3c29f3e0a842
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = python-sapply-git
+ pkgdesc = Apply a series of string manipulations on text easily.
+ pkgver = 0.1.9
+ pkgrel = 1
+ url = https://github.com/jmdaemon/sapply
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ depends = python-wora
+ depends = python-regex
+ depends = python-spacy
+ provides = python-sapply
+ conflicts = python-sapply
+ source = python-sapply-git::git+https://github.com/jmdaemon/sapply#branch=master
+ sha512sums = SKIP
+
+pkgname = python-sapply-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4d63012a8d08
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+pkgname=python-sapply-git
+pkgver=0.1.9
+pkgrel=1
+arch=('any')
+pkgdesc='Apply a series of string manipulations on text easily.'
+url='https://github.com/jmdaemon/sapply'
+license=('MIT')
+depends=('python' 'python-wora' 'python-regex' 'python-spacy')
+optdepends=()
+makedepends=('python-setuptools')
+source=("$pkgname::git+https://github.com/jmdaemon/sapply#branch=master")
+provides=(python-sapply)
+conflicts=(python-sapply)
+sha512sums=("SKIP")
+
+build() {
+ cd "$pkgname"
+ python setup.py build
+}
+
+package() {
+ cd "$pkgname"
+ python setup.py install --root "$pkgdir" --optimize=1
+}