summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWil Thomason2020-10-23 17:09:30 -0400
committerWil Thomason2020-10-23 17:09:30 -0400
commita6bd785df09d940f87be5ad6de0963b38709435c (patch)
tree4f7488c4e3ed73f4148fa8103bba09d30e6e6f5d
parentba917fa2398d9ec923bf38652b3603af9dfaffac (diff)
downloadaur-a6bd785df09d940f87be5ad6de0963b38709435c.tar.gz
Add missing dependencies
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD6
2 files changed, 5 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c3324cb03a1..726766796958 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,8 @@ pkgbase = python-scalene-git
makedepends = git
depends = python>=3.6
depends = python-numpy
+ depends = python-cloudpickle
+ depends = python-rich
provides = python-scalene
source = python-scalene-git::git+https://github.com/emeryberger/scalene.git
source = git+https://github.com/emeryberger/Heap-Layers
diff --git a/PKGBUILD b/PKGBUILD
index 7b82444ecdf0..14844283b14c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Wil Thomason <wbthomason at cs dot cornell dot edu>
pkgname='python-scalene-git'
-pkgver=r461.822c83d
-pkgrel=3
+pkgver=r698.5ba4693
+pkgrel=1
pkgdesc='Scalene is a high-performance, high-precision CPU and memory profiler for Python'
arch=('any')
url='https://github.com/emeryberger/scalene'
license=('Apache-2.0')
-depends=('python>=3.6' 'python-numpy')
+depends=('python>=3.6' 'python-numpy' 'python-cloudpickle' 'python-rich')
makedepends=('python-setuptools' 'make' 'clang' 'git')
source=("${pkgname}::git+https://github.com/emeryberger/scalene.git"
"git+https://github.com/emeryberger/Heap-Layers")