summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2022-09-06 09:08:44 +0200
committerPhilipp A2022-09-06 09:08:44 +0200
commitecb76f539bb3874b67fd0567ba9b9fb409ace636 (patch)
tree2c0ce4368edbc7a42190afe5641e41fde0ff6779
parent3538b1c8c9075d743e23f1b7da719b0d8476c1ea (diff)
downloadaur-ecb76f539bb3874b67fd0567ba9b9fb409ace636.tar.gz
v0.7.6
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD22
2 files changed, 17 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0715f2a402bd..48e41457f323 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,16 @@
pkgbase = python-scanpydoc
pkgdesc = A series of Sphinx extensions to get easy to maintain, numpydoc style documentation.
- pkgver = 0.7.3
+ pkgver = 0.7.6
pkgrel = 1
url = https://github.com/theislab/scanpydoc
arch = any
license = GPL3
+ makedepends = python-flit-core
+ makedepends = python-installer
+ makedepends = python-build
depends = python-sphinx
depends = python-get_version
- noextract = scanpydoc-0.7.3-py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py3/s/scanpydoc/scanpydoc-0.7.3-py3-none-any.whl
- sha256sums = 7036a038d29fde67580841351d2edae6ceeb9bf5f2364f5d656de78265c09e0e
+ source = https://files.pythonhosted.org/packages/source/s/scanpydoc/scanpydoc-0.7.6.tar.gz
+ sha256sums = 168d53c9b3fbf1775565e37cbf9a4ae014243f722ecfcc2e6fcb023749f4af95
pkgname = python-scanpydoc
diff --git a/PKGBUILD b/PKGBUILD
index e50b66e9c9f6..a6155cc86040 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,23 +2,23 @@
_name=scanpydoc
pkgname=python-$_name
-pkgver=0.7.3
+pkgver=0.7.6
pkgrel=1
pkgdesc='A series of Sphinx extensions to get easy to maintain, numpydoc style documentation.'
arch=(any)
url="https://github.com/theislab/$_name"
license=(GPL3)
depends=(python-sphinx python-get_version)
-_pyarch=py3
-_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
-source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
-sha256sums=('7036a038d29fde67580841351d2edae6ceeb9bf5f2364f5d656de78265c09e0e')
-noextract=("$_wheel")
+makedepends=(python-flit-core python-installer python-build)
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('168d53c9b3fbf1775565e37cbf9a4ae014243f722ecfcc2e6fcb023749f4af95')
+
+build() {
+ cd "$_name-$pkgver"
+ python -m build --wheel --no-isolation
+}
package() {
- local site="$pkgdir/usr/lib/$(readlink /bin/python3)/site-packages"
- mkdir -p "$site"
- unzip "$_wheel" -d "$site"
- #fix permissions
- find "$site" -type f -exec chmod 644 {} \;
+ cd "$_name-$pkgver"
+ python -m installer --destdir="$pkgdir" dist/*.whl
}