summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhilipp A2019-03-07 13:32:06 +0100
committerPhilipp A2019-03-07 13:32:06 +0100
commit55381d6149da62cf8f98e27c0429e27030071fbe (patch)
treee3edb384e1caf6bc6d07f98110ad759eba2f97ba
parentb82351623fa46af81d51c6dc4c7d942057ff8581 (diff)
downloadaur-55381d6149da62cf8f98e27c0429e27030071fbe.tar.gz
0.7.0
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD20
2 files changed, 16 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 19d659cdbd78..c587e60c5397 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,13 @@
pkgbase = python-schema
pkgdesc = Python module to validate and convert data structures.
- pkgver = 0.6.8
- pkgrel = 2
+ pkgver = 0.7.0
+ pkgrel = 1
url = https://github.com/keleshev/schema
arch = any
license = MIT
- makedepends = python-pip
- makedepends = python2-pip
- noextract = schema-0.6.8-py2.py3-none-any.whl
- source = https://files.pythonhosted.org/packages/py2.py3/s/schema/schema-0.6.8-py2.py3-none-any.whl
- sha256sums = d994b0dc4966000037b26898df638e3e2a694cc73636cb2050e652614a350687
+ noextract = schema-0.7.0-py2.py3-none-any.whl
+ source = https://files.pythonhosted.org/packages/py2.py3/s/schema/schema-0.7.0-py2.py3-none-any.whl
+ sha256sums = 5b0e0f47923164190513db2e91b9ab1941162b2dc400cc9b1803c2abab579e62
pkgname = python2-schema
diff --git a/PKGBUILD b/PKGBUILD
index 2ee0b01be3cc..340693fe1405 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,29 @@
_name=schema
pkgbase="python-$_name"
pkgname=("python2-$_name" "python-$_name")
-pkgver=0.6.8
-pkgrel=2
+pkgver=0.7.0
+pkgrel=1
pkgdesc='Python module to validate and convert data structures.'
arch=(any)
url="https://github.com/keleshev/$_name"
license=(MIT)
-makedepends=(python-pip python2-pip)
-_wheel="$_name-$pkgver-py2.py3-none-any.whl"
-source=("https://files.pythonhosted.org/packages/py2.py3/${_name::1}/$_name/$_wheel")
-sha256sums=('d994b0dc4966000037b26898df638e3e2a694cc73636cb2050e652614a350687')
+_pyarch=py2.py3
+_wheel="${_name/-/_}-$pkgver-$_pyarch-none-any.whl"
+source=("https://files.pythonhosted.org/packages/$_pyarch/${_name::1}/$_name/$_wheel")
+sha256sums=('5b0e0f47923164190513db2e91b9ab1941162b2dc400cc9b1803c2abab579e62')
noextract=("$_wheel")
do_package() {
depends=($1)
- $2 install --compile --no-deps --ignore-installed --root="$pkgdir" "$_wheel"
+ local site="$pkgdir/usr/lib/$(readlink "/bin/$1")/site-packages"
+ mkdir -p "$site"
+ unzip "$_wheel" -d "$site"
}
package_python2-schema() {
- do_package python2 pip2
+ do_package python2
}
package_python-schema() {
- do_package python pip
+ do_package python3
}