summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrej Radovic2021-07-29 09:23:20 +0200
committerAndrej Radovic2021-07-29 09:23:20 +0200
commit6cb56c83543b0bf05a251abb2d658b78d6572159 (patch)
tree59548740941438b75309b25605ed5f68ca83c82e
downloadaur-6cb56c83543b0bf05a251abb2d658b78d6572159.tar.gz
Initial commit.
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD23
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eb942da42288
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = python-schematics
+ pkgdesc = Python Data Structures for Humans
+ pkgver = 2.1.0
+ pkgrel = 1
+ url = https://github.com/schematics/schematics
+ arch = any
+ license = GPL3
+ makedepends = python-setuptools
+ depends = python
+ source = https://files.pythonhosted.org/packages/source/s/schematics/schematics-2.1.0.tar.gz
+ sha256sums = a40b20635c0e43d18d3aff76220f6cd95ea4decb3f37765e49529b17d81b0439
+
+pkgname = python-schematics
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a51b3b06182b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: Andrej Radović <r.andrej@gmail.com>
+pkgname=python-schematics
+_name=${pkgname#python-}
+pkgver=2.1.0
+pkgrel=1
+pkgdesc="Python Data Structures for Humans"
+url="https://github.com/schematics/schematics"
+depends=('python')
+makedepends=('python-setuptools')
+license=('GPL3')
+arch=('any')
+source=("https://files.pythonhosted.org/packages/source/${_name::1}/$_name/$_name-$pkgver.tar.gz")
+sha256sums=('a40b20635c0e43d18d3aff76220f6cd95ea4decb3f37765e49529b17d81b0439')
+
+build() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir" --optimize=1
+}