summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Handley2019-06-05 12:27:26 +0200
committerWill Handley2019-06-05 12:27:26 +0200
commit81c199c5650a5b858239db584fce4e5c971b5b8e (patch)
tree94cecd08dfc12b35e9e5eede83ae5379116f8835
downloadaur-81c199c5650a5b858239db584fce4e5c971b5b8e.tar.gz
First commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD26
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6072360c809c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = python-scholarly
+ pkgdesc = Retrieve author and publication information from Google Scholar in a friendly, Pythonic way
+ pkgver = 0.2.4
+ pkgrel = 1
+ url = https://github.com/OrganicIrradiation/scholarly
+ arch = any
+ license = Unlicense
+ makedepends = python-setuptools
+ makedepends = python-numpy
+ depends = python-arrow
+ depends = python-beautifulsoup4
+ depends = python-bibtexparser
+ depends = python-requests
+ options = !emptydirs
+ source = https://github.com/OrganicIrradiation/scholarly/archive/v0.2.4.tar.gz
+ sha256sums = cace82a7fb6c789eb4a8399e20f62cec5cc5f9c88a76c28f76d9bc2d0973b6eb
+
+pkgname = python-scholarly
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aafa632e0101
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Will Handley <wh260@cam.ac.uk> (aur.archlinux.org/account/wjhandley)
+_modulename=scholarly
+pkgname=python-$_modulename
+pkgver=0.2.4
+pkgrel=1
+pkgdesc="Retrieve author and publication information from Google Scholar in a friendly, Pythonic way"
+arch=(any)
+url="https://github.com/OrganicIrradiation/scholarly"
+license=('Unlicense')
+groups=()
+depends=('python-arrow' 'python-beautifulsoup4' 'python-bibtexparser' 'python-requests')
+makedepends=('python-setuptools' 'python-numpy')
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=(!emptydirs)
+install=
+source=("${url}/archive/v${pkgver}.tar.gz")
+sha256sums=('cace82a7fb6c789eb4a8399e20f62cec5cc5f9c88a76c28f76d9bc2d0973b6eb')
+
+package() {
+ cd "$srcdir/$(tar -tf v${pkgver}.tar.gz | head -n1)"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ mkdir -p "$pkgdir/usr/share/licenses/$pkgname"
+}