summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2023-07-10 02:38:10 -0300
committerDanilo J. S. Bellini2023-07-10 02:38:10 -0300
commita2580e105c73516d97a62e48ba8b434776f62cbe (patch)
treef775022dc0186e0d9deffe19ee831af77d5ed0cb
parentda05569238eb62ca828c3a9db7be25a5d1d0a0c8 (diff)
downloadaur-python-scielo-clea.tar.gz
v0.4.5-1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD10
2 files changed, 11 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35fbf960e66e..afdd4977a8f7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
pkgbase = python-scielo-clea
pkgdesc = SciELO Publishing Schema XML document front matter metadata reader/sanitizer
- pkgver = 0.4.4
+ pkgver = 0.4.5
pkgrel = 1
url = https://github.com/scieloorg/clea
arch = any
license = BSD
checkdepends = python-pytest
checkdepends = python-pytest-cov
- checkdepends = python-pytest-flake8
+ checkdepends = flake8
makedepends = python-setuptools
depends = python-lxml
depends = python-numpy
@@ -19,9 +19,9 @@ pkgbase = python-scielo-clea
optdepends = python-flask: development web server
optdepends = gunicorn: web server alternative
options = !emptydirs
- source = clea-v0.4.4.tar.gz::https://github.com/scieloorg/clea/archive/v0.4.4.tar.gz
+ source = clea-v0.4.5.tar.gz::https://github.com/scieloorg/clea/archive/v0.4.5.tar.gz
source = Vkbh7CKQDNQzX7bW3cQVdJx.json
- sha256sums = 52db2cf80c4b26f9164eb8122066dfa26310e5759c8a83c27847c64a18410d13
+ sha256sums = fd270f013fa3c2227bc7834bc904b9ac683c89fc2d883e4314d0f3b635dafa63
sha256sums = SKIP
pkgname = python-scielo-clea
diff --git a/PKGBUILD b/PKGBUILD
index 6bf9e6507f38..453579333817 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
pkgname=('python-scielo-clea')
-pkgver=0.4.4
+pkgver=0.4.5
pkgrel=1
pkgdesc="SciELO Publishing Schema XML document front matter metadata reader/sanitizer"
arch=('any')
url='https://github.com/scieloorg/clea'
license=('BSD')
makedepends=('python-setuptools')
-checkdepends=('python-pytest' 'python-pytest-cov' 'python-pytest-flake8')
+checkdepends=('python-pytest' 'python-pytest-cov' 'flake8')
depends=('python-lxml' 'python-numpy' 'python-levenshtein'
'python-ujson' 'python-click'
'python-regex' 'python-unidecode')
optdepends=('python-flask: development web server'
'gunicorn: web server alternative')
options=(!emptydirs)
-sha256sums=('52db2cf80c4b26f9164eb8122066dfa26310e5759c8a83c27847c64a18410d13'
+sha256sums=('fd270f013fa3c2227bc7834bc904b9ac683c89fc2d883e4314d0f3b635dafa63'
'SKIP')
source=("clea-v$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz"
"Vkbh7CKQDNQzX7bW3cQVdJx.json")
@@ -24,11 +24,15 @@ prepare() {
# Fix incomplete test file (add the missing expected result file)
ln -srf ../Vkbh7CKQDNQzX7bW3cQVdJx.json tests/json/
+
+ # Avoid python-pytest-flake8 while it isn't compatible with flake8
+ sed -i /-flake/d tox.ini
}
check() {
cd "$srcdir/clea-$pkgver"
python -m pytest
+ flake8 --ignore E501
}
package() {