summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDanilo J. S. Bellini2018-07-12 18:16:49 -0300
committerDanilo J. S. Bellini2018-07-12 18:16:49 -0300
commit667190a033ee2bc895d4eed0709e612d60c4cc5d (patch)
tree1f3eb8e26f03e7592d761bfa63d8f5bb83acda9e
downloadaur-667190a033ee2bc895d4eed0709e612d60c4cc5d.tar.gz
v1.33.1-1
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1f7425c63651
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = python-scielo-xylose
+ pkgdesc = SciELO's library to abstract a JSON from ISIS2JSON type 3 results
+ pkgver = 1.33.1
+ pkgrel = 1
+ url = https://github.com/scieloorg/xylose
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ depends = python-scielo-legendarium
+ options = !emptydirs
+ source = https://files.pythonhosted.org/packages/d8/05/0a3e2d7057c44bd0bf1133f3a3a2d8520a94e9bf7387fa31c56ef38d046f/xylose-1.33.1.tar.gz
+ source = https://raw.githubusercontent.com/scieloorg/xylose/0519212931883bd0dcc6d5dd476a710ff841dfee/LICENSE
+ sha256sums = 8e4bc2b4ea59850a2ee9b12a9e857440a05d25b76b4d75bf68afafb453026c6d
+ sha256sums = 611f9cee8598e86564f391797789c08e11877534727a9b235dce210bde17cf6b
+
+pkgname = python-scielo-xylose
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1bdab3509fc4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Danilo J. S. Bellini <danilo dot bellini at gmail dot com>
+_name=xylose
+pkgname=('python-scielo-xylose')
+pkgver=1.33.1
+pkgrel=1
+pkgdesc="SciELO's library to abstract a JSON from ISIS2JSON type 3 results"
+arch=('any')
+url='https://github.com/scieloorg/xylose'
+license=('BSD')
+makedepends=('python-setuptools')
+depends=('python-scielo-legendarium')
+options=(!emptydirs)
+sha256sums=('8e4bc2b4ea59850a2ee9b12a9e857440a05d25b76b4d75bf68afafb453026c6d'
+ '611f9cee8598e86564f391797789c08e11877534727a9b235dce210bde17cf6b')
+_pypi='https://files.pythonhosted.org/packages'
+_path='d8/05/0a3e2d7057c44bd0bf1133f3a3a2d8520a94e9bf7387fa31c56ef38d046f'
+_chash=0519212931883bd0dcc6d5dd476a710ff841dfee
+source=("$_pypi/$_path/$_name-$pkgver.tar.gz"
+ "https://raw.githubusercontent.com/scieloorg/xylose/$_chash/LICENSE")
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1
+ install -Dm644 ../LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}