summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlos Aznarán Laos2023-05-30 12:42:29 -0500
committerCarlos Aznarán Laos2023-05-30 12:42:29 -0500
commit620671ea91c1807a56d05b866f651d3edcc48790 (patch)
tree454944f28e312535051d985e46efc43719a8371e
parentb17cb5609ee85b2a2353c95538095061cf77a544 (diff)
downloadaur-620671ea91c1807a56d05b866f651d3edcc48790.tar.gz
Bump version to 2.1.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD28
2 files changed, 19 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41ee1489e9ec..d47bec73ddb2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-scienceplots
- pkgdesc = Matplotlib styles for scientific plotting
- pkgver = 2.0.1
- pkgrel = 2
+ pkgdesc = Format Matplotlib for scientific plotting
+ pkgver = 2.1.0
+ pkgrel = 1
url = https://github.com/garrettj403/SciencePlots
arch = any
license = MIT
@@ -11,7 +11,7 @@ pkgbase = python-scienceplots
makedepends = python-wheel
depends = python-matplotlib
conflicts = python-scienceplots-git
- source = SciencePlots.tar.gz::https://github.com/garrettj403/SciencePlots/archive/2.0.1.tar.gz
- sha512sums = 7fccf5aee720ee1920c3fa53f034acbbb9b7d391c67287490f50c42fbae2e5bb5f356108ab50e31fa3c67415ac469f537ec6362178498af4578475975056216e
+ source = SciencePlots.tar.gz::https://github.com/garrettj403/SciencePlots/archive/2.1.0.tar.gz
+ sha512sums = 6424b71a2c20d5d7c123f2c4658d98b4c29ec27898f2bbff3f71d238b07d614e9731169639a4ad020d2487a2824eddcefb41bb588ee7c57f57e9fad569681e25
pkgname = python-scienceplots
diff --git a/PKGBUILD b/PKGBUILD
index da5a0a18b8da..484fbf8e0d96 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,31 +2,31 @@
# Contributor: Andrea Feletto <andrea@andreafeletto.com>
_base=SciencePlots
pkgname=python-${_base,,}
-pkgdesc="Matplotlib styles for scientific plotting"
-pkgver=2.0.1
-pkgrel=2
+pkgdesc="Format Matplotlib for scientific plotting"
+pkgver=2.1.0
+pkgrel=1
arch=(any)
url="https://github.com/garrettj403/${_base}"
license=(MIT)
depends=(python-matplotlib)
makedepends=(python-setuptools python-build python-installer python-wheel)
source=(${_base}.tar.gz::${url}/archive/${pkgver}.tar.gz)
-sha512sums=('7fccf5aee720ee1920c3fa53f034acbbb9b7d391c67287490f50c42fbae2e5bb5f356108ab50e31fa3c67415ac469f537ec6362178498af4578475975056216e')
+sha512sums=('6424b71a2c20d5d7c123f2c4658d98b4c29ec27898f2bbff3f71d238b07d614e9731169639a4ad020d2487a2824eddcefb41bb588ee7c57f57e9fad569681e25')
conflicts=(python-${_base,,}-git)
build() {
- cd ${_base}-${pkgver}
- python -m build --wheel --skip-dependency-check --no-isolation
+ cd ${_base}-${pkgver}
+ python -m build --wheel --skip-dependency-check --no-isolation
}
package() {
- cd ${_base}-${pkgver}
- PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
+ cd ${_base}-${pkgver}
+ PYTHONPYCACHEPREFIX="${PWD}/.cache/cpython/" python -m installer --destdir="${pkgdir}" dist/*.whl
- # Symlink license file
- local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
- install -d ${pkgdir}/usr/share/licenses/${pkgname}
- ln -s "${site_packages}/${_base}-${pkgver}.dist-info/LICENSE" \
- "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
- install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
+ # Symlink license file
+ local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
+ install -d ${pkgdir}/usr/share/licenses/${pkgname}
+ ln -s "${site_packages}/${_base}-${pkgver}.dist-info/LICENSE" \
+ "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -Dm644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"
}