summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartino Pilia2018-03-27 07:38:20 +0200
committerMartino Pilia2018-03-27 07:38:20 +0200
commit3b0a66069bdbba227d58de5d21724a3d3770ca6e (patch)
treee00239b6a0784ed23b31cd665833ae658b2728f9
downloadaur-3b0a66069bdbba227d58de5d21724a3d3770ca6e.tar.gz
submit package (version 0.6.1)
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..895241651943
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = python-scikit-build
+ pkgdesc = Improved build system generator for CPython C, C++, Cython and Fortran extensions
+ pkgver = 0.6.1
+ pkgrel = 1
+ url = https://github.com/scikit-build/scikit-build
+ arch = any
+ license = MIT
+ makedepends = python-setuptools
+ depends = python
+ source = https://github.com/scikit-build/scikit-build/archive/0.6.1.tar.gz
+ md5sums = f5b79109e4314ff6bb02a20c38a3c817
+
+pkgname = python-scikit-build
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b9ad628c8a24
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer of this PKBGUILD file: Martino Pilia <martino.pilia@gmail.com>
+_name=scikit-build
+pkgname=python-${_name}
+pkgver=0.6.1
+pkgrel=1
+pkgdesc='Improved build system generator for CPython C, C++, Cython and Fortran extensions'
+arch=('any')
+url='https://github.com/scikit-build/scikit-build'
+license=('MIT')
+depends=('python')
+makedepends=('python-setuptools')
+source=("https://github.com/scikit-build/scikit-build/archive/${pkgver}.tar.gz")
+md5sums=('f5b79109e4314ff6bb02a20c38a3c817')
+
+package() {
+ cd "$srcdir/$_name-$pkgver"
+
+ python setup.py install --optimize=1 --root=$pkgdir
+
+ install -D -m644 ${srcdir}/$_name-$pkgver/LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}
+