summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEdwin Peters2018-02-06 11:24:15 +1100
committerEdwin Peters2018-02-06 11:24:15 +1100
commita8c74777761fb47c75486a5e5f79c4b590f2cf8c (patch)
tree9e5058cc393cc6e365f34619c4668d930b1ff198
downloadaur-a8c74777761fb47c75486a5e5f79c4b590f2cf8c.tar.gz
initial commit
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD29
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..01d0a65e9f30
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = python-scikit-cuda-git
+ pkgdesc = Python interface to GPU-powered libraries
+ pkgver = 57213a9
+ pkgrel = 1
+ url = http://scikit-cuda.readthedocs.org/
+ arch = any
+ license = BSD
+ makedepends = python-setuptools
+ makedepends = git
+ depends = python
+ depends = python-numpy
+ depends = cuda
+ depends = python-pycuda
+ depends = python-mako
+ depends = python-pytest
+ optdepends = python-scipy
+ optdepends = python-sphinx
+ optdepends = python-sphinx_rtd_theme
+ source = git+https://github.com/lebedov/scikit-cuda.git
+ sha256sums = SKIP
+
+pkgname = python-scikit-cuda-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a6e278246faa
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Edwin Peters <slimed13 at hotmail dot com>
+
+# You can always get the latest version on GitHub (those are unstable) with the
+# command:
+# sudo pip2 install --upgrade git+https://github.com/lebedov/scikits.cuda.git#egg=scikit
+
+pkgname=python-scikit-cuda-git
+pkgver=57213a9
+pkgrel=1
+pkgdesc="Python interface to GPU-powered libraries"
+arch=('any')
+url="http://scikit-cuda.readthedocs.org/"
+license=('BSD')
+depends=('python' 'python-numpy' 'cuda' 'python-pycuda' 'python-mako' 'python-pytest')
+optdepends=('python-scipy' 'python-sphinx' 'python-sphinx_rtd_theme')
+makedepends=('python-setuptools' 'git')
+source=(git+https://github.com/lebedov/scikit-cuda.git)
+sha256sums=(SKIP)
+
+package() {
+ cd ${srcdir}/scikit-cuda
+
+ # ignores any LDFLAGS set in makepkg.conf
+ unset LDFLAGS
+
+ python ./setup.py install --root=${pkgdir}
+
+}
+