summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-10-22 16:49:49 +0800
committerUniversebenzene2019-10-22 16:49:49 +0800
commit25ef51e6efce5393b973cb1835ea8602cc7c12f4 (patch)
tree6c43b694fd43cbc822229b670ad27abba21aa20c
parent580a6d3959e9fb01f5d34e3ba07e8c10f4bd93cd (diff)
downloadaur-25ef51e6efce5393b973cb1835ea8602cc7c12f4.tar.gz
Update to version 0.16.2
-rw-r--r--.SRCINFO16
-rw-r--r--.gitignore8
-rw-r--r--PKGBUILD10
3 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 501430b25c61..3a785850f527 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,19 @@
-# Generated by mksrcinfo v8
-# Thu Apr 11 02:44:38 UTC 2019
pkgbase = python-scikit-image
pkgdesc = Image processing routines for SciPy
- pkgver = 0.15.0
- pkgrel = 2
+ pkgver = 0.16.2
+ pkgrel = 1
url = http://scikit-image.org/
arch = i686
arch = x86_64
license = BSD
makedepends = cython>=0.23.4
- depends = python-numpy>=1.11
- depends = python-scipy>=0.17.0
+ depends = python-numpy>=1.14
+ depends = python-scipy>=0.19.0
depends = python-matplotlib>3.0.0
depends = python-networkx>=2.0
depends = python-pillow>=4.3.0
depends = python-pywavelets>=0.4.0
- depends = python-imageio>=2.0.1
+ depends = python-imageio>=2.3.0
optdepends = python-pyqt5: for imshow(x, fancy=True) and skivi
optdepends = python-qtpy
optdepends = freeimage: for reading various types of image file formats
@@ -24,8 +22,8 @@ pkgbase = python-scikit-image
optdepends = python-imread: Optional I/O plugin providing most standard formats
optdepends = python-simpleitk: Optional I/O plugin providing a wide variety of formats. including specialized formats using in medical imaging
options = !emptydirs
- source = https://files.pythonhosted.org/packages/source/s/scikit-image/scikit-image-0.15.0.tar.gz
- sha256sums = df111e654b47e5ea456c50553debe4c5ddd97258894c7ad3b7f2f9f10798e053
+ source = https://files.pythonhosted.org/packages/source/s/scikit-image/scikit-image-0.16.2.tar.gz
+ sha256sums = dd7fbd32da74d4e9967dc15845f731f16e7966cee61f5dc0e12e2abb1305068c
pkgname = python-scikit-image
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0d6e3b36c63a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+src
+pkg
+*.src.tar.gz
+*.tar.gz
+*.tar.bz2
+*.part
+*.pkg.tar.xz
+*.log
diff --git a/PKGBUILD b/PKGBUILD
index d41a1bc8fa4d..e3dc5dfd3725 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,14 @@
pkgbase=python-scikit-image
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
-pkgver=0.15.0
-pkgrel=2
+pkgver=0.16.2
+pkgrel=1
pkgdesc="Image processing routines for SciPy"
arch=('i686' 'x86_64')
url="http://scikit-image.org/"
license=('BSD')
makedepends=('cython>=0.23.4')
-depends=('python-numpy>=1.11' 'python-scipy>=0.17.0' 'python-matplotlib>3.0.0' 'python-networkx>=2.0' 'python-pillow>=4.3.0' 'python-pywavelets>=0.4.0' 'python-imageio>=2.0.1')
+depends=('python-numpy>=1.14' 'python-scipy>=0.19.0' 'python-matplotlib>3.0.0' 'python-networkx>=2.0' 'python-pillow>=4.3.0' 'python-pywavelets>=0.4.0' 'python-imageio>=2.3.0')
optdepends=('python-pyqt5: for imshow(x, fancy=True) and skivi'
'python-qtpy'
'freeimage: for reading various types of image file formats'
@@ -22,7 +22,7 @@ optdepends=('python-pyqt5: for imshow(x, fancy=True) and skivi'
'python-simpleitk: Optional I/O plugin providing a wide variety of formats. including specialized formats using in medical imaging')
options=('!emptydirs')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
-sha256sums=('df111e654b47e5ea456c50553debe4c5ddd97258894c7ad3b7f2f9f10798e053')
+sha256sums=('dd7fbd32da74d4e9967dc15845f731f16e7966cee61f5dc0e12e2abb1305068c')
build() {
cd ${srcdir}/${_pyname}-${pkgver}
@@ -30,7 +30,7 @@ build() {
python setup.py build
}
-package() {
+package_python-scikit-image() {
cd ${srcdir}/${_pyname}-${pkgver}
install -D -m644 LICENSE.txt -t "${pkgdir}/usr/share/licenses/${pkgname}"