summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2019-04-11 10:43:25 +0800
committerUniversebenzene2019-04-11 10:43:25 +0800
commit7aa30e2a3e9591fecfac774fe3560c5d940ba70e (patch)
tree4b9090698c4bc9290f5d46197dde31cc2cdf6b7a
parent7ffce5fa73779a9d28f27b1cf42e5108ff24edd9 (diff)
downloadaur-7aa30e2a3e9591fecfac774fe3560c5d940ba70e.tar.gz
Add depends
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD13
2 files changed, 22 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e9ef7c496116..6d568eee9f29 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,23 +1,27 @@
# Generated by mksrcinfo v8
-# Wed Apr 10 14:03:24 UTC 2019
+# Thu Apr 11 02:42:28 UTC 2019
pkgbase = python-scikit-image
pkgdesc = Image processing routines for SciPy
pkgver = 0.15.0
- pkgrel = 1
+ pkgrel = 2
url = http://scikit-image.org/
arch = i686
arch = x86_64
license = BSD
- makedepends = cython
- makedepends = python-six
- depends = python-scipy
- depends = python-matplotlib
- depends = python-networkx
- depends = python-pillow
- depends = python-pywavelets
- optdepends = python-pyqt4: for imshow(x, fancy=True) and skivi
+ makedepends = cython>=0.23.4
+ depends = python-numpy>=1.11
+ depends = python-scipy>=0.17.0
+ depends = python-matplotlib>3.0.0
+ depends = python-networkx>=2.0
+ depends = python-pillow>=4.3.0
+ depends = python-pywavelets>=0.4.0
+ depends = python-imageio>=2.0.1
+ optdepends = python-pyqt5: for imshow(x, fancy=True) and skivi
+ optdepends = python-qtpy
optdepends = freeimage: for reading various types of image file formats
optdepends = python-pyamg: fast cg_mg mode of random walker segmentation
+ optdepends = python-imread: Optional I/O plugin providing most standard formats
+ optdepends = python-simpleitk: Optional I/O plugin providing a wide variety of formats. including specialized formats using in medical imaging
options = !emptydirs
source = https://files.pythonhosted.org/packages/source/s/scikit-image/scikit-image-0.15.0.tar.gz
sha256sums = df111e654b47e5ea456c50553debe4c5ddd97258894c7ad3b7f2f9f10798e053
diff --git a/PKGBUILD b/PKGBUILD
index 7d9635314a0a..41ad6612a273 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,16 +6,19 @@ pkgbase=python-scikit-image
_pyname=${pkgbase#python-}
pkgname=("python-${_pyname}")
pkgver=0.15.0
-pkgrel=1
+pkgrel=2
pkgdesc="Image processing routines for SciPy"
arch=('i686' 'x86_64')
url="http://scikit-image.org/"
license=('BSD')
-makedepends=('cython' 'python-six')
-depends=('python-scipy' 'python-matplotlib' 'python-networkx' 'python-pillow' 'python-pywavelets')
-optdepends=('python-pyqt4: for imshow(x, fancy=True) and skivi'
+makedepends=('cython>=0.23.4')
+depends=('python-numpy>=1.11' 'python-scipy>=0.17.0' 'python-matplotlib>3.0.0' 'python-networkx>=2.0' 'python-pillow>=4.3.0' 'python-pywavelets>=0.4.0' 'python-imageio>=2.0.1')
+optdepends=('python-pyqt5: for imshow(x, fancy=True) and skivi'
+ 'python-qtpy'
'freeimage: for reading various types of image file formats'
- 'python-pyamg: fast cg_mg mode of random walker segmentation')
+ 'python-pyamg: fast cg_mg mode of random walker segmentation'
+ 'python-imread: Optional I/O plugin providing most standard formats'
+ 'python-simpleitk: Optional I/O plugin providing a wide variety of formats. including specialized formats using in medical imaging')
options=('!emptydirs')
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz")
sha256sums=('df111e654b47e5ea456c50553debe4c5ddd97258894c7ad3b7f2f9f10798e053')